Best answer

Salesforce error: Could not create a record of the "Lead" object.

  • 30 October 2023
  • 4 replies

Hi there,

I notice that from today my Zap are encounter this error:
“Error Message: Could not create record of the "Lead" object: You cannot create Lead from here, please open the standard form to create New Lead” at the end of the path of the Zap connection.


I tried to proceed with other test and also create a new Zap but I still meet the same error.
I turned the Zaps on from the last week and they worked well.
I start to meet these errors just from today.

How can I resolve this error?
Please help me as the activity is hot!

Thank you so much,



Best answer by CRMguys 8 November 2023, 15:18

View original

4 replies

Userlevel 7
Badge +14

Hi @CRMguys 

Good question.

To help us have context, please post screenshots with how your Zap steps are configured along with the encountered error.

It may be that settings in Salesforce prevent leads from being created via Zaps.

Userlevel 7
Badge +11

Hi @CRMguys, welcome to the Community!

I’ve been looking into this and noticed that you also reached out to our Support team about this. It appears they were able to dig into the logs and get some further details on what’s causing the error. Not sure if you’ve seen their reply yet but thought I’d share the key details from it here in case it’s helpful to you and anyone else that comes across this:

“I had a look at the logs, and they show the following error:


This error in Salesforce indicates that the data you're trying to input doesn't align with the validation rules that have been set up in Salesforce. Here's how you can troubleshoot this issue:

  1. Understand the Validation Rule: Review the error message you're receiving, as it should specify which validation rule is being violated. If no rule is specified, go to the Salesforce interface, navigate to the Object affected (in this case, the Lead object), and review its validation rules.
  2. Check Data Input: Compare your data against the validation rules. The issue could be something as minor as a certain field requiring a specific format, or a field being required that you've left blank.
  3. Modify Data or Validation Rules as Needed: Depending upon the needs of your business process, correct the data to meet the validation rules or adjust the validation rule if it's too restrictive.
  4. Test: After correcting the data or modifying the rule, test the process again to make sure the issue is resolved.

Remember, your Salesforce Admin or support should be able to assist with this if you're unsure of how to proceed. You should also exercise caution when adjusting validation rules, as those rules might be in place for important business reasons.”

Hope that helps. If you have any follow up questions on that I'd recommend continuing your conversation with the Support team directly over email as they'll be better placed to advise further. 🙂

Thank you for your answer...we had a problem with Salesforce connection.

Now all is working and running ;)


Userlevel 7
Badge +11

That’s great news @CRMguys! Thanks for letting us know, I’m so pleased you were able to get to the bottom of it! 🎉

Please do reach back out to the Community again if we can assist with anything else in future - always happy to help! 🤗