Best answer

Reporter field in Jira cloud is shown only till letter "T"

  • 1 November 2022
  • 5 replies

Hi everyone, 

I need some guidance or help for an issue we got. 

when setting up a zap to create ticket in Jira after a Google form was filled in

we wanted to set the reporter to be “Zappier_bot” - which is a legit jira user with all the permissions needed. 

But when we try to set this field in Zappier it shows the users only to letter “T” and no more … we need Z.

Has anyone bumped into such issue? What shall we do next? 

For now we have set the reporter to be Jira admin - me, but we would like to be able to set the zappier_bot user. 

It worked in our previous zapp that we just moved from one zappier user to this one. 



Best answer by Liz_Roberts 7 November 2022, 16:26

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +8

Hi @ft_jira_admin 


When choosing the value, you should see Load More on the bottom left corner, have you tried it? 

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Hi @MohSwellam  

I am attaching a screenshot with the view of the bottom of the field where is showing the lack of option to continue browsing for more users to be set as reporter.  as you can see the Load more button is gray and I am not able to load more users from the list to choose from. 



Userlevel 7
Badge +8

I see you are trying to search for the letter Z , that is why its showing these options. 


Another approach would be to call the user Admin_Zapier so it pops on the top 

Hi @MohSwellam,

Even if you do not type any letter but just scrolling down the list will end up with letter T. “Load More” button is greyed out and can’t be clicked. 


Moreover, if you search for users that begin with any letter after “T” one, for example V, no results are shown.


For the renaming approach - it will be very unpleasant experience to rename our users just because their first letter is missing from the list :(  


Userlevel 7
Badge +8

Hi @ft_jira_admin ! I see you’ve been working with Daniela in Support who helped get you squared away! Sharing her suggested workaround below in case other folks have a similar question. 😊


The Jira search is limited to the first 1000 results which cannot be changed (in this case, the 1000th result begins with “T”), however, each user in Jira has an ID which we can use for a workaround solution!


1.) We can add the Zapier bot ID to the Zap as a custom value.

  • You can find this value within your Jira account, through a find user step in Zapier or, if you already have a Zap in which you selected this user, you can get the respective ID from the dropdown.

2.) When you find the user ID, you'll want to click “Custom” and type/paste the ID into the Reporter field as shown below:

Make sure to paste it where it's written Enter text or insert data... and you should be able to create the issue linked to the Zapier bot user!