Best answer

Regfox Zapier integration error: Last name does not exist in Salesforce

  • 1 September 2023
  • 8 replies
  • 106 views

Im having issues with a simple Zap. I need to create a integration between Regfox and Salesforce.

Im using Salesforce for Non Profits so it has the additional object Service and Service Participants. 

When there is a new registration through Regfox I want it to create a new contact if it does not exist. If it does exist then add the Service Participant to the Service they registered for. Im getting an error from the beginning of just creating a Contact in Salesforce it is say that last name does not exist. 
 


 

icon

Best answer by ken.a 1 September 2023, 12:00

View original

8 replies

Userlevel 7
Badge +14

Hi @MarvintProjects 

Good question.

Try using the Find Record and enable the Create Record (via checkbox at the bottom) instead of Create Record.

 

Step 3 Error

 

Make sure to first test Step 2, as an ID of 1 for a Salesforce Contact is not a valid Salesforce Record ID format.

 

I tried that but I don’t understand what I am doing wrong. I also tried doing a simple just create a contact and it is giving me a missing last name error 

 

 

 

Ive also try doing a simple connection of creating contact:

 

 

Userlevel 7
Badge +14

@MarvintProjects 

The values from Step 1 have “No data”.

Make sure to test step 1 and pull thru data to use to test the action steps.

Help: https://help.zapier.com/hc/en-us/articles/8496310366093

 

 

Userlevel 7
Badge +14

@MarvintProjects 

Also, the Field to Search By should be selected from the dropdown list of options.

You’ll want to use a unique value. (e.g. email address)

For example, 2 people could have the same name.

 

Thank you I feel like I am getting closer but it looks like I don’t even have Last name as an option to edit. 

 

Userlevel 7
Badge +14

@MarvintProjects

 

Does it matter that it is a billing name? It should be just be last name. Billing last name is for a different field. 

Userlevel 7
Badge +6

Hi there @MarvintProjects,

I’m jumping in to see if I can help!

I did some digging into this, and it seems like RegFox trigger only provides us test sample when testing. I found that other users requested the same feature, and a feature request has been submitted. This is being handled by the dev team that created the integration and will take a closer look to support this request.

Your email has already been added to the interested users' list. I don't have an ETA of when this will be implemented, but we'll be sure that they will contact you when it is.

However, there’s a workaround for this one. Here’s what you can try:

  1. Map the fields from RegFox to your Salesforce step.
  2. Skip testing the action step, by clicking on the “Skip test” button.
  3. Publish the Zap.
  4. Trigger the Zap while it’s published.
  5. Go to your Zap history, and check the Zap run.
  6. Follow this awesome Community post on how to map fields that do not appear in the sample data: 

Hopefully, this helps! 😊

Reply