Best answer

Receiving Error: Invalid URL while trying to create Company Update on LinkedIn

  • 14 February 2024
  • 7 replies

Userlevel 1

Hey team! 

I’m currently running an automation to take a custom RSS feed, send it to GPT to get a summary, and then to google sheets, create an image for it, then post as a company update on linkedIn. 


The main error that I am finding is at the very bottom, where i am trying to create a company update to linkedIn. 


I am not sure what to do here. I have tried formatting it to try both https:// and without that at the beginning. I tried to replace it with ‘’ and the url field works, it just won’t work for any of the sites i’m using articles from? Not sure why i’m running into this error and only the URL field is not working. 


Best answer by Troy Tessalone 15 February 2024, 03:24

View original

7 replies

Userlevel 7
Badge +14

Hi @Herm1t 

For us to have full context, post screenshots with how your Zap step is configured in EDIT mode.

Userlevel 1

Sure, i’ll post more below, let me know if there’s something I missed. 

Inoreader works fine, when an article is uploaded to the folder it sends it to ChatGPT. 


ChatGPT then creates the content as a table and uses | as a delimiter for the next formatting step. 


The formatted text is split into clear output categories

A preview image is generated using Dall-E 3


And then the linkedIn company update is configured as above. I link the content from the google sheets as the update content (linkedIn post), then I give the article URL from Inoreader as the preview-URL, but that seems to be where i’m getting stuck. 

No matter what article is used it seems to not give updates, but if i change that field to something static like, or, then it DOES work properly. 

Userlevel 7
Badge +14


I don’t link web browsing is available via the ChatGPT Zap app actions.

Userlevel 1

Hmm, the only part of this that breaks for me is the very end though? 

I am successfully able to get the zap running if i take out the LinkedIn step, and it outputs the (successfully summarized) content to the google sheet, as I can show here


The only part that doesn’t work from here, is that when posting a company update to linkedIn, the zap fails because it of the URL failure. The web-browsing element is not the breaking point. 

Userlevel 7
Badge +14


Check to make sure there is no leading/trailing whitespace in the mapped variable value or before/after the mapped variable.


Make sure the mapped variable values adhere to the field descriptions.


Userlevel 1

That was the issue! thanks a lot, I added a formatter to remove it and it works now :) appreciate it

Userlevel 7
Badge +6

That’s awesome @Herm1t! Big thanks to Troy for pointing you in the right direction!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗