Best answer

QuickBooks Online error: “Invalid card verification number (cvv) Quickbooks Field: CustomerRef.value”

  • 21 June 2023
  • 3 replies
  • 51 views

Hello :),

 

im trying to synchronic my Stripe Invoices Account with my Quickbooks Account. I want Zapier to create the Stripe Invoices i got also in Quickbooks. I think i got the correct trigger and actions, but there is always this error, related to the CVV, but its only a invoice. What has the CVV todo with it?

 

Thank you for your help!

 

 

icon

Best answer by SamB 21 June 2023, 14:43

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +11

Hey there @Livarto! 👋

It looks like that error translates to “Invalid card verification number (cvv): Invalid card verification number (cvv), Quickbooks Field: CustomerRef.value”. But it mentions the CustomerRef.value, which I’m thinking would relate to the Customer field. So my guess here is that there might be an issue with the value that’s been selected for that field.

Does the Customer field use the Id number supplied by the Create Customer action, or are you using a different value for it?

If it’s not using the ID number can you try selecting the Id field from the Create Customer action and see if that then allows you to create the invoice without error?

Looking forward to hearing from you on this!

Hey there @Livarto! 👋

It looks like that error translates to “Invalid card verification number (cvv): Invalid card verification number (cvv), Quickbooks Field: CustomerRef.value”. But it mentions the CustomerRef.value, which I’m thinking would relate to the Customer field. So my guess here is that there might be an issue with the value that’s been selected for that field.

Does the Customer field use the Id number supplied by the Create Customer action, or are you using a different value for it?

If it’s not using the ID number can you try selecting the Id field from the Create Customer action and see if that then allows you to create the invoice without error?

Looking forward to hearing from you on this!

 

 

Thank you for your answer!

 

I put following Custom fields in there. Is something wrong with it?

 

 

Userlevel 7
Badge +6

Hi @Livarto,

I’m jumping in to see if I can help!

I looked at the screenshot, and it seems like the issue here is the mapped data in the “Customer” field in the “Create Invoice” action step. The “Customer” field looks for the Customer ID. Could you please try remapping the “Customer” field with the Customer ID coming from the 2nd step? The Customer ID should look like this:

caff7376d6adfa0ec5f043d2a0cb8d74.png
(view larger)

Please give that a try, and keep us posted! 😊