Best answer

"Provided dataset is not valid" error when trying to create lead in Pipedrive

  • 1 December 2021
  • 8 replies
  • 986 views

Userlevel 1

Hello there,

 

while i try to create a Lead in pipedrive from my funnel data i receive this error message while testing:

provided dataset is not valid "amount" is not allowed

But i can not find any field thats linked as “amount”.

The only field i am using a number from the funnel is the credit sum, but this is just a number right?

Does anyone have information what is the issue here?

 

Thank you all, best regards

Chris

icon

Best answer by SamB 1 December 2021, 10:43

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @Financial Admin 

Please post screenshots with how your Zap steps are configured, thanks.

Userlevel 1

Hi @Troy Tessalone 
thanks for your reply.

Of course. here are the steps:

 

  1. Lead Income from perspective Funnel

 

 

  1. Then i wasnt sure if i need these next two steps both but i tried to be sure, please correct me if i am wrong here :D (do you also need the detail steps / fields here as well?)
     

 

 

  1. And here i want to create a lead in pipedrive with the previously found / created data:

 

And this is the result of the last step:

 

I have no idea whats the issue here.

When i leave Value and Currency blank (which should not be an option) then the lead can be created.

 

Thank you very much for further support here.

 

BR

Chris

Userlevel 7
Badge +11

Hey @Financial Admin, thanks for sending over those helpful screenshots! :)

It looks as though you’re running into a known issue where the Value and Currency fields (fields usually associated with a Deal) are appearing on Create Lead actions. I’ve added you to the list of users affected by this. I can’t say when it will be resolved but as soon as it is we’ll send you an email to let you know. 

In the meantime, as you’ve already discovered leaving those fields blank should allow the lead to be created. Then you can use a Create Deal step to update the lead value and set a currency if desired. Hope that helps! 

Userlevel 1

Hi @SamB ,

thank you for the info.

In the Lead in Pipedrive the Value and Currency is also present and will be used absolutely in the workflow.

Honestly it is almost the most important data i would say :D

Do you mean to create and update the Lead or Deal ? On your second bold term you mentioned the Deal.

What i would think about is maybe create the lead as blank and then in next step to update this existing lead with the Value and currency, as you also proposed.
Or do you think that would not work with the lead as well?

 

BR

Chris

Userlevel 7
Badge +14

@Financial Admin 

Worth trying the recommendation of creating then updating the Lead via the Zap.

Otherwise, a workaround is to use the Pipedrive API to create a Lead: https://developers.pipedrive.com/docs/api/v1/Leads#addLead

App APIs can be used in Zaps with the Webhooks app: https://zapier.com/apps/webhook/integrations

Userlevel 1

Hi @Troy Tessalone ,

sounds like a plan, i will try that and provide feedback afterwards.

 

BR

Chris

Hi everyone on the thread.


@Troy Tessalone and @SamB, could you please add me as a user affected by the Value and Currency issue when creating a Lead?

How can I track the progress of this issue?

 

Thank you in advance,

Vlad

Userlevel 7
Badge +9

Hi there, @Vlad-AP! Thanks for reaching out. 

I’ve added you to the list of impacted users! While we don’t have any updates to provide at the moment, we’ll definitely send an email and update the thread as soon as we know more. 🙂