Question

Product description filter only works using Stripe Legacy and not the current Stripe version

  • 3 September 2022
  • 15 replies
  • 60 views

Hi everyone -- I have perused essentially all of the articles on this and cannot find a solve, and I believe it’s because stripe has changed the filter information available lately. I am trying to help a client set up stripe filters to trigger into flodesk, as her clients purchase specific products from her. 

 

The filter option is not giving me anything that has the names of her products. Multiple products of hers are the same price, and she occasionally offers coupon codes, so the amount filter does not work. 

 

I personally somehow have access to Stripe Legacy in my Zapier -- and that allows me to use the product description filter, so it works fine, but that is missing from the current Stripe integration. 

 

Has anyone seen this issue? Is there something I should be adding to her Stripe data? Please help! This has been immensely difficult. 


15 replies

Userlevel 1

I’m having this same issue, would love to know if anyone finds a solution.

Userlevel 4
Badge +6

Hi @alexac90 and @Jbeans 

 

Can you please share screenshots of your current Zap setup so we can help you better?  

 

For example, are you using the Trigger New Invoice (With Line Items Support)? You can learn more about that here https://zapier.com/help/doc/common-problems-stripe

Hi. I am using the “new payment” filter, because “invoice” only pulls non-repeating payments. I need this to be applicable to subscription purchases as well. Let me know if this is incorrect. 

This is what I do first. 

Then, my stripe is connected, and I move to add a filter. 

 

I am then searching for the names of my products within the filter, and nothing comes up as a field to contain that data. I am sure I’m missing something, but this was NOT the case on stripe (legacy). Please tell me what to do!!! 

 

Userlevel 1

Interesting, my issue is that “New Invoice” is only pulling subscription payment items and NOT one-time payments. 

Interesting -- now it’s only pulling subscriptions! Zapier team -- can you confirm if this trigger is able to pull ALL stripe payments, subscriptions & one-off items included? 

 

Okay as an update, my client is only able to see her certain invoices here, not all of her products, and the test data is just not pulling anything relevant to her brand currently (no products she’s sold within the last two years). Any idea what’s happening? 

 

I tried this with my own Stripe, and it did work! 

Userlevel 7
Badge +9

Hey there, @alexac90! Thanks so much for reaching out in the Community. So sorry to hear you’re still running into this. 😔

I’d actually recommend opening a ticket with my friends in support for this one. That way they can dig into this a bit more with by pulling the logs for your specific zap. 

Feel free to link them to this Community topic as well! 

Please keep us posted with your findings - we’d love to know! 

Userlevel 1

Hey @alexac90 I spoke to support as per @christina.d recommendation and they’re suggestion was to use the “new payment” zap and filter it by “calculated_statement_desc” as it “should contain the products name.” I got super excited and saw on Stripe you can set a custom statement descriptor per product so I did all that but unfortunately Zapier is still only pulling my general company statement descriptor and not pulling any individual item descriptor information. Might be worth a shot on your end to try? I’ll keep you posted on what they say but please let me know if you find a solution as well.

Thanks!

Userlevel 1

Hey @alexac90 I found a new solution! It looks like there is a new trigger on the Stripe event for “Checkout Session Completed” and this seems to pull customer data and product data that you can filter before your action zap.

Try it out!

Userlevel 7
Badge +8

That’s awesome, @Jbeans- thanks for sharing!! Marking your solution as the best answer here but @alexac90 be sure to let us know if this doesn’t do the trick!

 

That’s awesome, @Jbeans- thanks for sharing!! Marking your solution as the best answer here but @alexac90 be sure to let us know if this doesn’t do the trick!

It does not do the trick, therefore I would not mark this as best answer… 

This is getting a little insane. I use Zapier a ton, and recommend it to all of the small business owners I consult for, but this stripe filter has gotten so difficult to use I need to switch to something else. The product filter works now, so I CAN see the product my clients are purchasing, but it’s not pulling any of their information necessary to complete the zap (name or email). Any recs ?? 

Userlevel 7
Badge +12

Hi @alexac90!

I’m sorry that you’ve been having so much trouble getting the information that you need for this Stripe Zap.

Can I double check something? You said that the Zap isn’t pulling in the name or email, do you meant that there’s a field for it that has no data in it, or that the field isn’t there at all? 

If it’s the first one, then the first thing to do would be to try pulling in a new sample for the test data. If you still get something that says ‘no data’, could you try completing the Zap (you may have to skip testing some steps so that you can publish it), turning it on then running a test transaction through Stripe to see if the data is there when the Zap is live?

Thanks!

It’s not saying ‘no data’, it’s not saying anything at all. I see the capture field for the data, but nothing following that. I need to use the trigger for ‘checkout session completed’, because this is the only trigger that pulls ‘line items description’, but nothing is coming up. 

Userlevel 7
Badge +12

Thanks for your reply and the screenshot, @alexac90

 

Did you try pulling in a new sample from the trigger data? If you did and still didn’t get information in those fields, could you try setting up your Zap by adding the field for the data where you need it to be and when the Zapier editor asks you test the step, click the Skip Test button

 

When you’ve built the Zap and either tested or use ‘Skip test’ where you need to (eg where name is a required field) then Publish the Zap and send a test transaction through Stripe to see if the data comes through when the Zap is live. 

 

Let us know how that goes :) 

Not working. I’m getting an alert that says the email field is missing. What’s especially annoying is that I already HAVE two of these set up perfectly, when it was Stripe (Legacy). Of course, that’s not available through Zapier anymore… for whoever knows why. This is so frustrating - I will need to cancel my subscription and all of my clients need to go back to the drawing board unless you can all figure out what is going on. 

 

Reply