Question

Problem with Xero data structure for postal and delivery addresses

  • 11 April 2024
  • 3 replies
  • 42 views

Hi all,

I’m trying to create a Zapier Interface form that, once completed, creates a new Customer Record in Xero with the data from the form.

My issue is with the Registered Address and Shipping Address (or Postal Address and Physical Address, as Xero calls it).

Background:

  1. The CSV export from Xero for Customer Records contains individual columns for each subsection of each address.
    • POAddressLine1, POAddressLine2, POAddressCity, POAddressRegion, etc for Postal Addresses
    • SAAddressLine1, SAAddressLine2, SAAddressCity, SAAddressRegion etc for Shipping addresses
  2. I have created a Zapier Table which mirrors the structure of this CSV file, and from that have created an Interface, selecting and ordering the important fields that I want the customer to complete, and hiding irrelevant fields (for the customer) such as Account Number, Tax Codes, Invoice Branding Theme, etc. 
  3. I then tried to set up a Zap, linking the Interface with Xero. Mostly it’s straightforward to map the data (shown below), but there is an issue with the addresses
    Straightforward Data Mapping. A field in Xero can be linked with a field in the Interface/Zapier Table

Problem

When is comes to the addresses, during the Action step of the Xero part of setting up the Zap, there is a Xero field: “Address Type Of”, and I can only select 2 options: Postal Address or Physical Address.  This field is not in the CSV file, but I suppose it’s Xero’s was of distinguishing between the POAddress fieldS and the SAAddress fields.

 

After selecting either Postal Address or Physical Address, there is only one set of address data. You cannot distinguish or map the Postal or Physical address separately.

 

 

Therefore, it seems it’s only possible for this Zap to update include one address. Our clients mostly use third-party warehouses, so it’s important for us to record both addresses at client onboarding.

Any assistance in how to deal with this (or get around it!) would be much appreciated!

Thank you!

Bernard


3 replies

Userlevel 7
Badge +11

Welcome to the Community, @bvanv! 😁

You’re quite right. I had a quick look and I couldn’t see an option to add more than one address either. There aren’t any existing feature requests for the ability to add multiple addresses so I’d recommend reaching out to our Support team to get a new feature request submitted for this. 

In the meantime, can you add an additional Create/Update Contact (Xero) action to update the contact that gets created? And in the setup of that second Xero action you’d put in the second address that needs to be added. My thinking here is that it if you select the other available option for the Address Type Of field on the second Xero action, that might then allow you to add the second address without overwriting the existing address, as it’s a different type of address. 

Could you give that a try and let me know if that works as hoped?

Thanks for your answer, @SamB! It’s a nice idea, to split it into two steps.

 

Unfortunately while trying that I’ve hit another hurdle. As suggested, I made the first step of the Zap to create the initial record in Xero with the Postal Address data. When testing this step, although in Zapier it says the zap was successful and the data was sent to Xero, nothing ‘arrived’ in Xero. There was no record created. I also tried filling out the Interface form a couple of times with dummy data, and had the same issue. The Zap happened successfully in Zapier, but nothing was created in Xero.

 

I tried disconnecting and reconnecting the Xero/Zapier accounts several times, but no luck. I also looked at some of the other Xero troubleshooting articles and ‘common problems with Xero’ page, but none of those issues seem to match this one. The closest I found was this:

The recommendation there was to open a ticket with Zapier Support. Would you suggest the same here, or is there another known solution? 
Thanks,

Bernard

Userlevel 7
Badge +11

Happy to help @bvanv! 🙂 

Sorry to hear you ran into another issue with the Xero app here. It’s very strange that the action was successful but the new contact wasn’t added. 

If you look at a recent run in the Zap History, under the Data Out tab it should provide a Contact ID number for the contact that was added. Can you try searching for the contact in Xero to see if it’s there? If it’s not possible to search by the contact’s ID number in Xero, can you temporarily add a Find Contact action to the Zap to see if it’s able to find a contact that has the same ID that appeared in the Zap History? 

I did some checking on this end but couldn’t see any existing bug reports to match the issues described here. It could be that this is a new bug that’s recently developed and you’re the first one to reach out to us about it. So it may well be worth reaching out to Support to have this investigated further. You can do that here: https://zapier.com/app/get-help

Looking forward to hearing from you on this!

Reply