Best answer

Problem with Google Sheets to Webflow CMS Zap - fields.slug’ invalid input

  • 22 January 2024
  • 4 replies
  • 81 views

I’ve been fighting with the Webflow API for the last couple of days to try and get it to accept a slug when pushing data from Google Sheets to Webflow CMS using Zapier.

Weirdly it was working a couple of times yesterday when I tried and then it just stopped working. I haven’t been able to get it to work all of today.

No matter what I try to enter in the ‘slug’ field in Zapier, I keep getting the error:

“‘fields.slug’ invalid input”.

This is what I’ve tried…

Properly formatted slug:

Screenshot 2024-01-19 110604

Slug without spaces:

Screenshot 2024-01-19 110628

Empty slug field:

(this caused a validation error because the slug is a required field)

Screenshot 2024-01-19 111123

Using the title as the slug:

Screenshot 2024-01-19 112629

Manually entering the slug:

Screenshot 2024-01-19 111453

I noticed in Zapier the ‘slug’ field in the test had a lowercase ‘s’:

Screenshot 2024-01-19 112800

So I changed the slug label in the Webflow CMS to also have a lowercase ‘s’:

 

Screenshot 2024-01-19 111052

Screenshot 2024-01-19 111052782×127 4.44 KB

 

It made no difference :upside_down_face:

I’m not the first person to run into this problem. People are facing the same problem with passing the slug value from Google Sheets to Webflow for the last few years.

All the suggestions in those earlier threads have not worked.

I feel like I’ve tried every permutation I can to try and get the slug field passed into WebFlow CMS but it’s just not accepting it.

Is WebFlow broken or is Zapier broken?

I certainly feel broken after trying to figure this out for the last couple of days.

icon

Best answer by Troy Tessalone 22 January 2024, 17:35

View original

4 replies

Userlevel 7
Badge +14

Hi @Streamalive 

For us to have more context, we would need to see more screenshots that show full context about how your Zap steps are outlined and configured, thanks.

Hi Troy, hopefully this is some more context.

Here are the fields I have in WebFlow. The Title and Slug don’t have to be the same. Both are required fields in the WebFlow CMS.

 

Here is the Zap steps I have - push from Google sheets to Webflow when any row is updated. I have deleted the original Zap and started fresh for these screenshots.

 

This is the text Zapier has found for the Slug column (I tried using a capital ‘s’ and a lowercase ‘s’ in earlier Zaps but it made no difference). I selected this record for the test:

When I set the Zap action, I noticed that the Slug field doesn’t have an asterisk next to it, even though it should be a required field like the Name field.

In my WebFlow settings, the Slug field is definitely labelled as a Required Field, so I wonder why it is not labelled as a required field in the Zapier screenshot above?

When I go to test the Zap, I noticed that the Slug field has become a lowercase ‘s’.

 

After clicking the Test button, I get this error message back:


Does this provide more context? Something strange is going on with this Slug field.

Userlevel 7
Badge +14

@Streamalive 

 

Possible workarounds are to try using the Webflow API via one of these advanced approaches:

 

If you suspect a bug with the Webflow action, then you can open a ticket with Zapier Support here: https://zapier.com/app/get-help

I fixed this issue for me by removing spaces after the text using TRIM(XXXXX) in the google sheet I was pulling from. 

Reply