Question

Problem syncing Facebook page to Google Business page


Since April, My “Facebook Page to Google Business profile” is not syncing anymore. 

I deleted the zap, and started again, gave all permissions to the new Zappier App in Facebook and Zapier can read my Google page perfectly.

But now, I can't find the way to map the contents of the Facebook posts to my google business page.

 

It says “Invalid argument” 

Does someone have the correct mappings or settings to make this work? 
Thanks,

 


6 replies

Userlevel 7
Badge +14

Hi @vra1974 

Help us have more context by posting screenshots with how your Zap steps are outlined and configured along with the encountered error.

Hi @vra1974 

Help us have more context by posting screenshots with how your Zap steps are outlined and configured along with the encountered error.

Here they are:

Userlevel 7
Badge +14

@vra1974 

You may have to try process of elimination to determine the field that is causing the error.

Related topic with the same issue.

 

Userlevel 7
Badge +11

Hi there @vra1974 👋

I suspect the issue might be to do with the value that’s been selected for the Photo Source URL field:

82dff078ce11f443a12b3247c57efeb0.png

Does the link contained in that Picture field contain a publicly-accessible link to the image file? 

If not, could you try selecting the Full Picture or Full Res Picture fields from the Facebook Pages trigger to see if that then allows the post to be created in Google My Business without error?

Looking forward to hearing from you on this!

Hi there @vra1974 👋

I suspect the issue might be to do with the value that’s been selected for the Photo Source URL field:

82dff078ce11f443a12b3247c57efeb0.png

Does the link contained in that Picture field contain a publicly-accessible link to the image file? 

If not, could you try selecting the Full Picture or Full Res Picture fields from the Facebook Pages trigger to see if that then allows the post to be created in Google My Business without error?

Looking forward to hearing from you on this!

Hi!

I edited the actions to NOT include any picture. It worked.

But then, I tried every facebook field available, and in every one, said 

Failed to create a post in Google Business Profile

Couldn't create a post for this location: Request contains an invalid argument.


Then I copied the URL of the facebook link to the picture on the post, and it says “

URL signature expired

On every url of the post picture contents (Full Res, Unshimmered, Etc)

So, I think this is what is happenning. Zappier is sending the text “URL signature expired”  as picture to google.

Is there a way to fix this?

 
Userlevel 7
Badge +11

Thanks for giving that a try @vra1974

Hmm, that “URL signature expired” error would indicate that the URL selected from the Facebook Pages post has since expired. Facebook Pages generates URLs that grant temporary access the post image for a short amount of time - this shouldn’t be a issue when the Zap runs live though as the Google Business Profile action will run seconds after the Zap triggers.

To fix this, in the Facebook Pages trigger can you bring in a new test record that has a new image URL that hasn't expired yet? Then test the Google Business Profile action again to see if it is then able to post the image?

Reply