Piperdrive "Deal Status" trigger not working

  • 11 April 2022
  • 7 replies



I’m trying to set up a zap that detects when a deal in Pipedrive is first assigned a specific Deal Status, and message a slack channel.


Through testing, the zap works perfect (pulls the right data and messages the slack channel), however when I turn on the zap I can’t get it to fire by updating deals in Pipedrive.


I’ve tried both the “Updated Deal Stage” and “Deal Matching Filter” trigger options.


Can anyone suggest what might be causing this to not trigger?



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @blinc 

Good question.

After turning the Zap ON and testing, check your Zap Runs for possible errors:

Userlevel 7
Badge +14


Zapier had an incident that may be related per their Status Page:



I also have the same issue, the trigger is an updated deal status (it should be instant).

When I created the zap, everything worked well. When I tried a real test into Pipedrive, the zap is not running.

I looked at the zap history and there are no zap running which is weird.

Does anyone know how solve that problem ? 

Thanks in advance.



Userlevel 7
Badge +14

Hi @Alexandre Legrand and @blinc 

Both Pipedrive and Zapier have had recent incidents that may be related, altho not sure.


May be best to open a ticket with Zapier Support:




Has this issue been resolved? i am having the same issue, using Updated Deal Stage In Pipedrive as the trigger, everything works well during the test when setting up however after publishing it does not trigger at all.




Userlevel 7
Badge +14

Hi @BeauWoods 

As a workaround try using this Zap trigger: Pipedrive - Deal Matching Filter


Userlevel 7
Badge +9

Hi there @BeauWoods, @Alexandre Legrand, and @blinc! Thanks so much for reaching out. 

I’m sorry to hear about this! Have ya’ll had an opportunity to open a ticket with our friends in support? They should be able to dig into this for ya’ll and see what the underlying issue is. It’s certainly possible you’re being impacted by a bug and if so the team can log this for you. I’d definitely recommend linking them back to this post as well so there’s some added context.

Thanks again and definitely keep us in the loop!