Pipedrive error: Neither an Organization nor a Person was provided. One of them must be provided to create a lead.

  • 23 June 2023
  • 8 replies

I am trying to set up a ‘zap’ which would send form submissions using a Klaviyo form through to Pipedrive as a lead. While I’ve got the two platforms connected and data pulling through from Klaviyo:

Which seems to be discoverable in the Pipedrive options:

I’m getting what I assume is a mapping error when I try to submit the test:

I can see on another post that there is a reported bug for a similar problem: 

But would like to know if this falls into the same hole in terms of a known issue or if I’m actually doing something wrong with the execution?


Thanks for any help,



8 replies

I thought I’d sorted it after seeing another topic:

However, I now have the following setup:

Which allows me to get to this:

But which then still results in this:


Userlevel 7
Badge +11

Hi @JCPW, welcome to the Community!

I think the bug reported on the other topic in Community is related to a different issue than the error you’re running into here.

I believe that “Failed to create a lead in Pipedrive” error is due to the name for the Person and Organization being selected instead of the ID. When selecting a custom value for a dropdown menu field like those Person and Organization fields you’ll need to supply the ID for the item you want to select, not it’s name.

As you’re getting the person and organization details from Klaviyo, any IDs it gives will be specific to Klaviyo and not applicable to Pipedrive. So you’ll likely need to add Find Person and Find Organization search actions to the Zap to locate the relevant person and organisation in Pipedrive and get the correct IDs. 

You can learn more about using custom values and using search actions to find existing content here: 

Hope that helps to get you pointed in the right direction. Please do keep us in the loop on how it goes!

Thanks @SamB - not exactly intuitive, but I think I’ve managed it. Will give it a test this afternoon, but it’s published, so it’s a good start!

Userlevel 7
Badge +11

Glad I could help @JCPW. 🙂

Hopefully that’ll fix it but please do reach out if you run into any issues when testing. Always happy to further assist! 

Hi @SamB


The tests are now going through to the sandbox, but actual form fills are not going through to the live account. Not sure where I’m going wrong now, honestly. Tearing my hair out a bit!


Thanks for your help with all of this - apologies for the handholding I’m asking for!

Userlevel 7
Badge +11

Totally no need to apologise here @JCPW


Are the Pipedrive action steps in the Zap connected to a sandbox environment instead of the live one? If so, that could be why it’s not sending them to the right place.

In which case you’ll need to change the connections that are selected on all the Pipedrive actions in the Zap to make sure that the Zap is connected to the live environment instead.

If your web browser was still logged into the sandbox environment then when connecting it likely automatically connect to that Sandbox account. So you’ll want to log out of Pipedrive completely or add the new Pipedrive connection in a different web browser private browsing/incognito window. More on this here: Connect multiple accounts of the same app to Zapier


Hope that helps! 🙂

Hi @SamB sorry to keep going - the test is now pulling through into Pipe drive, but new form fills are still not being added. I currently have a 10 minute delay after adding the person and organisation before the zap attempts to add the lead - is that sufficient? There is a two stage sign-up which requires following an emailed link, but even if that's clicked quickly, it's not pulling through. Apologies for taking your time on this, but I've tried everything I can think of now! 


On the plus side, I think I'm going to write up the process once I've got it working, so if anyone as daft as me comes along you can hopefully point them to that. 😂

Userlevel 7
Badge +6


I’m jumping in to see if I can help!

Regarding the 10-minute delay, it should be sufficient in most cases. However, if the two-stage sign-up process takes longer than this, it might be causing the issue. You might want to consider increasing the delay to ensure that the sign-up process is fully completed before the Zap attempts to add the lead.

If you've already checked these and the issue persists, I'd suggest reaching out to our Support team so that they can dig deeper into the logs, and take a closer look at the Zap. They can provide more insight into what might be going wrong. You can reach our Support team here:

Hopefully, this helps! 😊