Question

Odoo error: Failed to create a lead in Odoo CRM, ValueError: "name 'Env' is not defined" while evaluating Console logs

  • 23 August 2022
  • 4 replies
  • 188 views

I get the error " Failed to create a lead in Odoo CRM"   when I test action on Odoo CRM, I looked in to troubleshoot  "ValueError: <class 'NameError'>: "name 'Env' is not defined" while evaluating Console logs:" and it says that I have a bad request 400 required field is missing or a field value wasn't in a recognized format.

I checked the required field which is "opportunity" and the format of the other fields like email and name, but it won't work.

any help please


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @Arbi 

Good question.

Please post detailed screenshots for each Zap step in order for us to have more context, thanks.

Hey @Troy Tessalone

in the 3rd step of creation action "Create Lead in Odoo CRM”, i set up the fields to be used by Zap Opportunity, Customer name and Customer Email, i maked sure to insert the correct fields from Wix Automation. In The last step when i make test before publish it shows this error

 

The only field required here is “Opportunity” 

and this is the 2 others fields that i’m using:

i can’t see my error where it is, Can you help me please!

Userlevel 7
Badge +14

@Arbi 

The value being tested with is not a valid email address.

Value in bold is the field label from a previous step.

Value in gray is the value for the field.

 

Help article about how to change your trigger test data: https://zapier.com/help/create/basics/change-the-test-data-in-your-zap-trigger

Make sure to test your Wix Automation before pulling in new Zap trigger step example data to use to configure the other Zap steps.

 

 

Userlevel 4
Badge +5

Hey, @Arbi! Just wanted to check in to see if Troy’s response pointed you in the right direction. Do you still need help here?