Question

Notion.so | "Find Database Item in Notion" - Can't find item by date filter

  • 3 May 2023
  • 5 replies
  • 359 views

My goal is for Zapier to find a Notion item based on a date field called “Expiration date”.

Within the Zap, I am given 2 options that are pertinent to the step: 

  • Expiration date filter (of which I can choose from the following options: before, after, equals, on_or_before, etc) - set to “equals”
  • Expiration date (actual value of the field) - populated as today’s date.

Each item in my Notion database has a unique value in its “Expiration date” field, so ideally, this step will search for the item who’s date is today. I’ve already setup steps earlier within the zap to determine today’s date and format it as YYYY-MM-DD, and it outputs correctly. 

The problem is that when the step tries to find the the item with a date matching today’s it returns no results even though there is most definitely an item that exists and matches. 

Does anyone know why this isn’t working? When I set the date filter to “on_or_after”, it pulls up the item for tomorrow, but it doesn’t find the item for today, but it finding tomorrow’s confirms that my date is formatted correctly.

See screenshots below:

step that gets today’s date from previous step and formats it to match notion’s schema.
settings within “Find Database Item in Notion”

 

failed search

 


5 replies

Userlevel 7
Badge +9

Hey there,  @kayyydennn! Thanks so much for reaching out in community - sorry to hear you’re running into this!

I know this may seem silly but are you able to check the timezone in your Zapier account and the actual zap itself to make sure they all are set to PST?

In your Zapier account itself. You can change this in your settings, and it will reflect in all of your Zaps that don’t have a specific time zone already set. In the Zap itself. Each Zap can have its own time zone set, and this will override the setting in your Zapier account. You can check that by clicking the gear on the right side of any Zap.

If it’s helpful here’s an article specifically on date/time fields for a few other troubleshooting steps that might be worth checking out:

Keep us posted!

Thank you for your reply! My zapier account is currently set as follows:
 

and the individual zap as follows:

I don’t believe that to be the issue. Any other ideas?

Userlevel 7
Badge +6

Hi there @kayyydennn,

I’m jumping in to see if I can help!

I looked at the screenshot, and it seems like there are no issue with the timezone settings. That said, have you tried using the “on_or_before” option in the “Expiration date filter” drop-down field? If so, please let us know the results.

Thanks! 😊

I tried setting it to on_or_before and it also did not work, but setting it to before seemed to be working but then depending on the time of day, it will still fail to locate the item with the desired date. It seems that there is some sort of mismatch taking place still, but I can’t see how it would be a timezone issue. 

Feeling discouraged :( 

 

Userlevel 7
Badge +6

Hi @kayyydennn,

I apologize, but I have exhausted my ideas and resources on this issue. I recommend contacting our Support Team so that they can dive deeper into the logs on why this issue is happening.

You can reach our Support team here: https://zapier.com/app/get-help

Thanks! 😊

Reply