Best answer

Notion error:  Unable to load pages and getting “No options available”

Userlevel 1

Hi all,

I’m trying to setup Zap to create page every month. My account is Workspace owner in Notion, tried to re-generate connection multiple times, but Zapier is unable to load pages - I’m getting “No options available” and the prompt says that everything was loaded. I cannot select any parent page for my Zap.

In Notion, the requested parent page is shared via the created connection. I even tried to share the whole Teamspace for the Zapier, but no luck there.

Could you please assist what am I missing? 


Best answer by ken.a 16 May 2024, 13:08

View original

6 replies

Userlevel 7
Badge +14

Hi @CloudTalk 

Help articles for using Notion in Zaps:


I gave Zapier full access to all of my pages, but new pages don’t appear

If you create new pages after connecting to your Notion account and want to interact with them in your Zaps, you'll need to grant Zapier permission in your Notion account. This is because Notion’s API requires you to specify permissions for each page that Zapier can access.

My databases are not listed in the dropdown menu

If you're having trouble listing your database in your Zap, try these steps:
After trying these steps, you should be able to refresh your fields and view your database in your Zap.
Userlevel 1

I’m having the exact same issue. I have been connecting to pages fine. And my existing zaps can still access Notion pages. But any new zaps I create will not list my Notion pages.

Userlevel 7
Badge +6

Hi @Sage,

Have you tried using the Page ID that you want to use as a custom value? More about that here:

Kindly give it a try and let me know how it goes? I'll keep an eye out for your response!

Userlevel 1

That was an awesome idea and and worked perfect. Thank you SOOOOO  much!


I will say, however, it’s weird that it can’t fetch the page names right now. I can fetch databases. 


What ever. You fixed my problem. Thank you!

Userlevel 7
Badge +6

That’s awesome @Sage! I’m glad I was able to help with the workaround.

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Userlevel 1

Thank you for answer @ken.a 

I was able to retrieve page UUID in 1 step and then use this result to create another page.