Best answer

No pictures in LinkedIn posts


Hi,

 

I would like to share an RSS-Feed to my LinkedIn. I seems like this is a standard use case: https://zapier.com/apps/rss/integrations/linkedin

 

However, when I try this I only get the link in my LinkedIn post - no pictures. When I copy the link and post it manually on LinkedIn it loads a picture. How can I get the pictures via Zapier, too? (see screenshots)

 

Thank you! 

 

icon

Best answer by ken.a 22 May 2023, 06:00

View original

9 replies

Userlevel 7
Badge +6

Hi there @CZap,

Welcome to the Community! 🎉

I have been doing some digging on this and I see that a few other users have been running into this problem. As it turns out, you've run into a known bug. Our team is aware of the issue and is working on a fix. I've added your email address as another affected user. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

Thank you for understanding.

In Zapier, set up the RSS to LinkedIn integration as you normally would, following the instructions provided in the link you shared.

After configuring the RSS feed and LinkedIn accounts, you should reach a step where you can customize the post content. This is where you can include the images from the RSS feed.

To include the images, you will need to use a feature called "Zapier Formatter." Zapier Formatter allows you to manipulate data within your Zapier workflow.

In the "Zapier Formatter" step, choose the action "Formatter by Zapier" and select the "Text" option.

In the "Transform" field, you can use a simple HTML code to embed the image from the RSS feed. Assuming the image URL is available in the RSS feed,

@ken.a I noticed that the majority of the response to this inquiry have been that this is a known bug that Zapier is working on. 

  1. Can you add me to the aforementioned list for updates when this bug is fixed. 
  2. Can you point me to the version/feature where this bug is going to be resolved? Is there a release that the team is planning to have this released upon? Or is there feature that I can help upvote somewhere? 

Much Thanks!

Userlevel 7
Badge +6

Hi there @mpmodrak,

I have added you to the list of affected members of the bug.

For a variety of reasons, the way we currently handle bugs is quite "opaque". There could be a lot of work going on behind the scenes, but the only information we're currently able to share is when the bug is fixed, and nothing in between, which can often give the impression that nothing is being done when that's certainly not the case.

The main reason for that is with over 5,000+ different integrations on Zapier, priorities are changing and shifting constantly, and with so many different variables at play, some of which are completely outside our control (e.g. are we reliant on partners to make changes?), it's just not possible to offer any accurate timeframes on bug fixes.

With that in mind, all we can say is that a bug has been logged, we're working on getting it resolved as quickly as we can, and we'll let you know as soon as that happens.

In the meantime, I'm certainly doing everything I can to pass on feedback like this to help ensure that the impact of these issues is clearly understood.

I know that none of this changes the fact that you're still waiting on fixes, but I hope it goes some way towards reassuring you that we're doing our best to get them fixed as quickly as we can.

Thank you so much for your patience and understanding.

Please let me know when the bug of images not being uploaded to LinkedIn via Zapier is fixed. Thanks.

Userlevel 7
Badge +6

Hi @rvana,

I have added you to the open bug report. We will keep you in the loop via email once the bug has been fixed.

I appreciate your patience and understanding.

@ken.a  When is this going to get fixed? Also running into this issue. 

Looks like the bug has been known for at least a year. About time this gets fixed.

Userlevel 7
Badge +6

Hi @iliasbeshimov,

I understand that experiencing an issue can be frustrating, and I am sorry for any inconvenience this may have caused you.

I have added you to the open bug report. Unfortunately, we can’t provide a timeframe for the bug’s fix and we consider the complexity of the bug, how many users are affected, and the scope of the issue when we prioritize issues. It also depends on whether the issue cause lies solely in our control or if we need to work with our partners at other apps to resolve it, so the timeframe can range. 

I appreciate your patience and understanding.

Any updates on this? I’m finding posts that are 1+ year old about not being able to share photos to LinkedIn through Zapier (trying to repost Facebook posts with this Zap)

Reply