Question

"New subscription in Stripe" triggered twice

  • 21 September 2023
  • 3 replies
  • 57 views

Userlevel 1

Hi,

I’m using zapier to integrate stripe to twist(chat tool). 
What I’m trying to do is simple if/then workflow - if a new subscription is created in stripe then post to twist. But every time I test, it is triggered twice and it looks effected by “invoice.payment_successful” and ”invoice.paid callback”.

I’m wondering why this is happen in such a simple workflow. Have anyone experience same trouble? And how fix that?

Thank you in advance.
Yuto


3 replies

Userlevel 7
Badge +11

Hello there @issues! 👋

That’s very odd, I’d have expected that New Subscription trigger to run for webhooks coming from the subscription_schedule.created Stripe endpoint. This sort of behaviour seems likely to be a bug. I did some digging on this end but couldn’t spot any recent reports of this mentioned for the trigger. So it could just be that this is a bug that you’re the first one to spot! I’d suggest reaching out to our Support team to have this investigated further. You can get in touch with them here: https://zapier.com/app/get-help

In the meantime, does the New Subscription trigger provide anything different between the two runs that are triggered each time? Just thinking that if there’s a field or certain value that’s always different between the two runs of the Zap then you could set up the Zap to filter out one of the duplicated runs. Not an ideal solution I know but hopefully it’ll help while those duplicate triggers are still occurring.

Looking forward to hearing from you!

Userlevel 1

Hi @SuaTV ,
 

Thanks for your reply! I took a look my setting after you commented, and find a mistakes…
Appreciate your help and sorry for bothering you.

 

Best,
Yuto

Userlevel 7
Badge +11

It’s no bother at all, @issues! Out of curiosity, what change did you make to get the Zap triggering correctly? I’m sure there may be other folks in Community in a similar situation that would benefit from knowing how you solved it. 🙂

Reply