New Leads sent to Salesforce won't add to Campaign

  • 13 October 2022
  • 5 replies

I have a 3 Step Zap.  When I have new leads come from my landing page, Zapier creates the lead in Salesforce, then adds the lead to a campaign. I’ve tried half a dozen tests this morning.  All with unique names, phone numbers and emails.  The leads are created, but not added to campaign. Zapier emails me and says leads are already in the campaign.  I’ve sent tests from different computers, thinking maybe its matching IP addresses. Still the same, “lead is already in campaign”. Any ideas what could be causing this?

5 replies

Userlevel 7
Badge +14

Hi @jclynn 

Good question.

Please post detailed screenshots with how your Zap steps are configured in order for us to have context, thanks.

Also, if you turned the Zap ON and tested live, then you can check the Zap Runs history details to see the data IN/OUT for each Zap step to help you troubleshoot:


As I send the pictures I think I understand what is happening…Its using an actual lead, call the lead “John from Charlotte” (I blacked out the actual leads information) from the landing page to sync everthing from step 1 to step 2, but I think with Step 3 it’s actually trying to add “John from Charlotte” to the campaign every time a new lead signs up.  So I’m guessing I’ve set this up wrong.  Just not sure how to correct it.  Thanks!

I just set this Zap up yesterday, first one I’ve ever done by myself.  Hasn’t worked since setup test.


Userlevel 7
Badge +8

Hi @jclynn, I believe you are correct in where things are going wrong. This happens when things aren’t mapped out 100% correct, and/or custom fields are used. Unfortunately, I don’t think I’d be of much help here without being able to see the information in the fields. Please reach out to Support and they can get you squared away in no time!