Best answer

New Feedback trigger in Usersnap unable to pull real trigger samples when testing.

Hi - does anyone have a successful Usersnap Integration with Zapier? I am trying to integrate it with Intercom to create a new inbound message whenever Feedback is created in Usersnap, and I’m stuck at the testing phase. 

I have new feedback created in Usersnap but the Test Trigger does not detect the feedback. I’m not sure why - any help would be appreciated. 

Thank you!


Best answer by ken.a 24 March 2023, 06:08

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

10 replies

Userlevel 7
Badge +9

Heya @0x Project! Thanks for reaching out in community - we’re so excited to have you.

Hmm, do you mind if I ask what Usersnap plan you’re on? We have a note on our end that says only Startup plans and above have access to the Zapier integration. Their help docs also mention it here. It doesn’t look like they have lower plans then that currently but wanted to double check. 🙂

If you are on the Startup Plan or higher, are you on the latest version of Usersnap? I think they migrated to a new platform sometime in the last year and Zapier only works with the latest one. If you are on the older platform it’ll say Classic in the top right corner and you’ll need to migrate to the latest version. 

I hope some of this helps! Keep us posted! 🧡

Userlevel 7
Badge +14


Would be great to have internal note as a help article on the Usersnap Zap app profile page:

@christina.d Thank you for your response. 

1. We are on the “Company” level plan with Usersnap and have an active subscription (not trial).​​​​​​
2. We are not on the “Classic” version of Usersnap - we just signed up a week ago. 

I even tried deleting my existing space in Usersnap and creating a new one. I created a few test feedback options but still didn’t get the trigger.

The only thing I’m not sure about is that I don’t have the Usersnap JavaScript installed onto my product, but the Integration with Zapier is already connected, and the space is turned on (Live) in Usersnap, so I’m not sure if that might be it but not sure. 

Additionally - if I just “skip” the test, and proceed with creating the Zap, should I then test it out when it’s “Live”? Maybe that might work? 


Userlevel 4
Badge +6

Hi @0x Project 

Regarding the Usersnap Javascript, I looked at our help docs, and it seems unnecessary for the Zapier integration. You can take a look here:

Also, if you skip the test, you won’t be able to map the fields in the action step because the information from the trigger step is needed to map the action step.

If it’s still not getting any sample trigger for the trigger step, then this can be a bug we can report.

I’ll keep an eye out for your response!

Hi @Brem ,

Yeah I think it might be a bug in that case as I have not been able to successfully get that event to trigger in Zapier.

Would you happen to know if there are other customers that have a Usersnap integration and are encountering the same issue? 


Okay weird - I just did a refresh and it found some Data? I will need to continue investigating but that didn’t happen earlier. 

Actually, the data seems off b/c this is not me (I created the feedback):


Nope, nevermind - that was example data that Zapier created I think:


If you hit “Test Trigger” it then thinks it found feedback and asks you to Continue.

Userlevel 7
Badge +6

Hey @0x Project,

It looks like the trigger is using a “fallback” sample data since it couldn’t find any test data to use. I tested this on my end, and it seems like the “New Feedback” trigger has a “Project” field in the “Trigger” section of the trigger step.

Could you please ensure that the correct Project is selected on the “Project” field?

Thanks! 😊




It is set to the correct “Project”.

One thing I would like to point out is, I’m using the built-in Demo page that Usernsap has to test the Feedback creation. I don’t have actual feedback in our Product that is being created - just demo feedback. 

Could that be why nothing is getting triggered?



Userlevel 7
Badge +6

Hey @0x Project,

Thanks for all of those additional information!

I’m unfamiliar with the Usersnap integration, but you mentioned using a Demo page for the feedback creation. That could be the issue here.

To test, please try using the other projects under the “Projects” dropdown field and check if the trigger will fetch any feedback.

Thanks! 😊