Question

Name field is not populating from jotform to Zapier

  • 26 May 2023
  • 8 replies
  • 170 views

I have a zap that sends an automatic text message (through click send) when someone fills out information on a form (in jotform). The tests I perform on zapper are pulling in the name field, but the actual zap is not. It keeps leaving the name field blank. I have tried everything and cannot figure out what's wrong. I have another zap that pulls in the name field just fine. 


8 replies

Userlevel 7
Badge +14

Hi @micaelacook 

Good question.

We’ll need more context.

Please post detailed screenshots with how your Zap steps are configured along with outlining a specific example.

Thank you for the response. I have a zap set up that does the following .

Anytime, a new form is submitted on Jotform. It should trigger a text message to be sent from click send. The text message should pull in the name field from the jotform submission. When I test the zap it pulls in the name field from a previous form and sends the text message with the name filled in. However, the name field is not pulling in when the zap is published, it's leaving the name field blank. I have the function on another form and it works just fine. Ive tried deleting the zap and remaking it. I can't figure out what the issue is. 

Userlevel 7
Badge +14

@micaelacook 

We’d need to see a screenshot with the Zap Run DATA OUT from Jotform in Step 1 to have enough context.

 

 

here it is!

Userlevel 7
Badge +14

@micaelacook

That screenshot shows the name as part of 1 field called Your Information.

 

That may mean something isn’t configured correctly on the Jotform.

I deleted the question and recreated it, it still doesn't work. I copied a jotform that I already use with the same process and it doesn't have issues. Ill screenshot that one and send it

 

It literally makes no sense. The name field subcategory is pulling up as an option, and the zap test works properly and autofills the name

Userlevel 7
Badge +14

@micaelacook 

We’d need to see how the Jotform is configured and why those 3 fields are “grouped”.

 

A possible workaround is to use a Webhook: https://zapier.com/apps/webhook/help

Jotform Webhook help: https://www.jotform.com/help/245-how-to-setup-a-webhook-with-jotform/

 

Zap trigger would be Webhook - Catch Hook which will generate the webhook URL to place in Jotform.

Reply