Best answer

My Zap is creating blank multiple select field option

  • 4 April 2024
  • 3 replies

i have a zap with a Find Record step in Airtable. the step is set up to create the record if one is not found. for creating the record, i have text in a multi-select field that corresponds to one of the multi-select field options. however, when the zap actually creates the record, it adds both that option as well as a new blank option. i have double checked to make sure i don't have spaces before or after the option i entered. any ideas about how to prevent this from happening? thanks!! (below is a screenshot of my zap)



Best answer by SamB 5 April 2024, 12:51

View original

3 replies

Userlevel 7
Badge +11

Hello there @AI_hello! 🙂

I know those sorts of fields for Airtable will create a new option if it’s not an exact match for an existing option so capitalisation is super important to get right so that it’s able to select the correct option. But it’s very strange that it’s making a blank option as well, despite no unexpected space characters being present. 
Can you try the following steps:

  • Completely clear the value in that Segment(s) field.
  • In Airtable, remove the blank option that the Zap added.
  • Then test the Find Person (Find Record) action for a record that doesn’t exist so it will create a new record.

I’d like to check whether it still creates a record and adds a blank option for the Segment(s) field. If it doesn’t add a new blank option for that field again, can you then do the following:

  • Type in a different option name into that Segments(s) field in the Zap.
  • Then test the Find Person (Find Record) action again with a search value that will ensures that it attempts to create a new record.

The above tests will help to identify if it’s creating a blank option in the field regardless of whether a value is selected or whether it’s only happening for the “Individual donors” option or for other selected options too. 

Can you give the above a try and let me know how you get on?

thanks so much for the reply! it looks like it stopped happening, so i don't know if one of the things i tried worked or there was some weird backend glitch that got resolved. weird! but thank you so much for trying to help me!

Userlevel 7
Badge +6

That’s great news @AI_hello! We’re glad to hear that the issue is now resolved!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗