MightyForms zap: Project: no results found

  • 9 November 2023
  • 8 replies

Userlevel 1

I am trying to create a zap between MightyForms and Memberpress. I am stuck on the MightyForms step “Trigger.” It prompts me to choose a value for a “project” (required). When I click “choose value” it opens a search bar but I cannot get anything to generate from that. I have tried copying and pasting the title of the form. I tried pasting data from the form’s URL. Heck, I even tried typing every letter of the alphabet in uppercase, then lowercase as well as numerals 0-9 but nothing I enter generates anything. 

There is a tab labeld “custom” and the instructions say I can enter something but there is nowhere to enter anything in that custom tab.

I am connected to MightyForms, and it is the correct account. The form is published in MightyForms. I am the owner and sole user of the MightyForms account so permissions should be good (I cannot find anywhere in my MightyForms account to adjust permissions regardless).

I am using the free version of Zapier. This is a simple zap I’m attempting to create. 

I am using Chrome. 


Here’s a video demonstrating the above. 



8 replies

Hey @MollyCMo 

The first thing I would try would be to re-connect the Mightyform account. 

Press Account - change - connect new account. 

Once you have done this see if the issue persists. 

Steven Da Silva

Systems With Steve 

Userlevel 1

Thank you Steven,

I tried that yesterday about 100 times. :) 

It may be worth noting that I had a lot of trouble trying to connect to the app via Zapier. It kept saying my email and/or password were incorrect and I am 100% certain they are correct. I logged out and back in to MightyForms several times. I finally just connected via Google and that worked. Since logging in with Google I have attempted reconnecting and changing the account and the trigger issues remain. 

Fair enough haha. 

Have you tried making a new zap and have you tried in an incognito tab as well? 

Userlevel 1

Lol 🙂 

Yes and yes. I deleted the zap and created a new one from scratch, did that three times actually. 

I also tried incognito mode. No luck! 

I just created an account, made a test form, connected to Zapier and the project (form) showed up on my end.

Is it an option to create another Mightyforms account and then reconnect to your Zapier account? Maybe just try this to see if it’s an issue that’s specific to your account login issues. 



Userlevel 1

Oh wow, that gives me hope! 

I could create a free account with mighty forms and try this to see if that works for me too. But we do have a paid account with mighty forms and that’s the one we want to use eventually. 

I will try this and report back.

Userlevel 1

Okay Steven, in trying your suggestion above, I stumbled upon the solution, which was something different altogether - I tried connecting to MightyForms via Zapier by connecting via Google again, but this time connected via a different Google profile of mine, and that worked! The weird thing is that both my Zapier account and MightyForms account were created under the previous Google profile I was trying to connect through. So it’s a mystery to me how or why it worked to connect via the profile that these accounts are NOT under, but maybe I just don’t understand profiles as well as I thought. 🤷 When I switched back to my previous Google profile, it did not work.

I’m glad I found a way to make this work, but it seems it’s going to be an annoying step to switch over to my other Google profile any time I want to do something in Zapier. But for now, it’s a workaround!

That is frustrating…. 

I would recommend creating chrome profiles for your different google accounts. So when you open your profile its only logged into one account. 

Can help avoid something like this in the future.