Question

Microsoft To Do task only creates in default and shared lists

  • 29 August 2023
  • 9 replies
  • 103 views

I set up a zap to create a MS TODO task whenever an e-mail in my gmail account is starred. All works well, except the only two lists I can create the task in are the default list and some random shared list someone shared with me. I can’t choose any of my other TODO lists in the zap (they don’t show up as options when I set up the zap).

Any help would be appreciated. Thanks!

 


9 replies

Userlevel 7
Badge +14

Hi @bn9 

Good question.

To help us have more context, please post detailed screenshots with how your Zap steps are configured along with the field you are having the issue with.

Does this help?

I set up my Gmail and MS TODO accounts, set the action title to be the subject and message URL (so I can click on the task and it takes me straight to the relevant e-mail), and then for the list I wanted to choose “CBC emails” but it only gives me those two options in the screenshot.

Userlevel 7
Badge +14

@bn9 

If you know the internal ID of the List (blacked out for the 2 Lists shown), then you can try using the ‘Custom’ mapping option.

 

How do I find the internal ID? And do you know why the other lists aren’t showing up by default and why these ones are (the default “Tasks” one makes sense, and the “Flagged Emails” sort of makes sense but why “Projects” and none of the others?).

Userlevel 7
Badge +14

@bn9 

Sometimes you can see the internal ID in the browser URL.

Check the List type (settings/permissions)

Check your Zap app connection: https://zapier.com/app/connections

The browser URL didn’t work. I tried turning on sharing and using that token ID, but that didn’t work either.

The settings and permissions look fine, but maybe I’m missing something? There aren’t too many options on the MS side…

And my Zap app connection is working (the Zap is actually working when I use the default MS TODO list, I just want it to go to a list other than the default one).

Any other suggestions? Any other way to get the list ID that the Zap app recognizes?

Userlevel 7
Badge +14

@bn9 

You can try searching other Zapier Community topics for related issues/solutions.

I tried but didn’t find solutions only similar issues.

Might be a bug/limitation with the Microsoft To Do Zap app integration.

 

If you have a Zapier paid plan, you can try opening a ticket with Zapier Support here: https://zapier.com/app/connections

Thanks for the help. I’ll try searching as you suggest. If anything else comes to mind, please let me know, and if I find a solution I’ll post it here.

 

Userlevel 7
Badge +6

Hi there @bn9,

I did some digging into this, and I was able to confirm that you're being affected by an issue with the Microsoft To Do app, where the Create Task action isn't displaying any lists or it doesn’t display the correct list in that “List” dropdown. But if you use the ID of that list as a custom value, it will work properly.

Our team is aware of the issue and is working on a fix. I've added your email address as another affected user. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

Thank you for your patience and understanding.

Reply