Best answer

Microsoft Teams error: Unable to create channel: A team owner must install the Zapier app from the Teams store to use this feature, then reconnect your Microsoft account in Zapier

Userlevel 1



Up until yesterday I haven’t had any issues relating to adding a new channel to a team within MS Teams, but after duplicating an existing Zap and modifying it, I am no longer able to create a channel in MS Teams. I’ve followed the guide to remove/uninstall it from the channel, and add it again. I’ve tried adding multiple accounts to this App, but nothing appears to resolve the issue, both of which are owners of the Teams channel. During the setup of this step, I am able to test a connection and it shows successful. I’m not sure what else can be done. I’ve also attempt to recreate an entirely new Zap but the issue persists. As mentioned earlier, I’ve had no issues until this afternoon.


The error is as follows below


“Failed to create a channel in Microsoft Teams

Unable to create channel: A team owner must install the Zapier app from the Teams store to use this feature, then reconnect your Microsoft account in Zapier.”


Best answer by SamB 20 April 2023, 16:29

View original

13 replies

Userlevel 7
Badge +11

Hi @dshaines, welcome to the Community! 

Sorry to hear that reinstalling the app didn’t work. Has anything changed with the permissions of the connected Microsoft Teams account lately? 

It looks like the Microsoft Teams app requires the connected account to have one of the following roles:

  • Global Administrator
  • Security Administrator
  • Security Reader
  • Privileged Role Administrator

You mentioned that the accounts you tried to connect were owners but I’m wondering if they need to specifically have one of the above roles instead?

Can you try connecting with a different account that is a Global Administrator for example and see if that works? Looking forward to your reply! 🙂

Userlevel 1



I have tested with my account which is a GA within the tenant and also an owner of the Team group.


Userlevel 7
Badge +11

Thanks for confirming that @dshaines!

I’ve been doing some further digging on this end and it looks like we’ve actually got a bug report open for the Microsoft Teams app that appears to match what’s happening here. I’ve added you to the list of affected users so we’ll be in touch by email as soon as that’s fixed.

There’s no known workarounds reported but I wonder if you might be able to create the channel using the API Request (Beta) action event for Microsoft Teams instead?

You can find that action event here:

I’ve not tested this out but it looks like the Create channel API endpoint is the one you’d want to make a request to. I’d recommend checking out the Create an API request in your Zaps (Beta) guide for details on how to set up this type of action.

The API Request event is an advanced feature though so may not be a great workaround here. But thought I’d suggest it in case it helps to get your workflow working in the meantime! 🙂

Userlevel 1

Hey SamB!


I have tried using your recommendation of “Microsoft Teams API Request” but am getting an error when attempting to load the action. 



Any other assistance you can offer?

Thank you,

Userlevel 4
Badge +6

Hi @dshaines 

I can see that the Support Team replied to your ticket, and you’re in conversation with them. Here’s the last reply from Pedro:

I did suspect it could be related to this bug, but wanted to double-check if the setup on your end would be related. 

I see that Sam added you to the bug report as an affected user which adds more weight to the issue and ensures that you'll be notified once it's fixed. 

I'm sorry, I wish I had a more immediate solution for you! 
Other users reported that their Microsoft user had Global Administrator and other roles like Teams Administrator simultaneously, and that updating the user to have only "Global Administrator" solved the issue for them. 
I cannot guarantee this will work out for you, but it is worth the try!

In this case, it will be best to keep the conversation going with them as they can dig into the error logs of your Zap with you to look for the cause of the errors and to help you with the API request.

Userlevel 1

I encountered this same issue after changing the email address on my Zapier account (having initially set it up as a trial for my company using my own email, now that it’s moved to production the login changed to a company admin email).

No amount of removing / re-adding the Zapier app in Teams and disconnecting / reconnecting the Teams app in Zapier resolved the error. Interesting to note however that after installing the Zapier app on another Team I was able to create a new channel in that Team, while the Team that I need to create channels in is sadly still not working.

I was able to get around it using a custom API request, but not in the Teams app. When I try Teams - custom API request, it throws a “Raw request failed” error. However it does work when I instead use an Azure AD step to post to the same create channel Graph endpoint. Not sure why, but I’ll take the win and hope it remains stable.

Userlevel 7
Badge +6

Hi @jasonsamuels-w4sight,

I’m glad to hear that you found a workaround for this one. In the meantime, I have added you as another affected member to the open bug report. While we don’t have a timeframe on when this bug will get fixed. We will let you know via email once it is.

Thank you for your understanding.

Userlevel 1

Hey @jasonsamuels-w4sight . I went a similar route by removing the Teams API from my Zap entirely after it’s broken several times over the past few months. Workaround was to setup an API within our tenant, generate a bearer token with a POST webhook to that API, then add/create the channel via GRAPH with the bearer token from the previous step.

May help you but it took me a while to get around it breaking.



Userlevel 1

@dshaines we’re using the exact same method, right down to the request syntax. The only difference between this and Zapier’s API Request (Beta) step is that you don’t have to generate and include a bearer token because the app connection handles authentication.

Userlevel 1

@jasonsamuels-w4sight - Thanks for that! Going to look into that today.

Userlevel 1

Odd thing to note - there’s a slight difference syntax in my workaround compared to what @dshaines posted above - I have “IsFavoriteByDefault” set to false

With that setting at true, the Microsoft API returns a 403 error (code: Forbidden; message: Error. Maximum number of default channels reached: 10/10). 

Although I encountered that in testing, I tried it one more time on the live Zap and sure enough it hit the error again. When I patched up the job by creating the channel manually in the Teams GUI, I set the flag to show the channel to everyone by default there, and in that scenario it popped up an error on screen but the channel actually was created.

Userlevel 1

@jasonsamuels-w4sight - We ran into that issue before too.I wish I could find the documentation that I referred to for the isFavoritebyDefault, but what I read was that the Team itself could only display a total of 10 channels to users(show for members). At the request of the user, we wanted to ensure the newly created channel didn’t show under ‘Hidden Channels’ and this resolved that issue for them. There is a slight bit of upkeep on the users end to ensure that only channels relevant are displayed. They keep the number of “show for members” to below 10 to ensure that when the Zap fires again, it doesn’t fail.

Userlevel 1

@dshaines oh. I just went back and counted how many channels we had set to “show for members” and of course was 10. Cleared some of them in Teams, then tried again and my original Zap works again. I’m sticking with the API call that sets it to false though, because that’s easier to keep going and less ongoing maintenance.

Zapier’s Create Channel is Microsoft Teams action doesn't allow you to specify the “show for members” setting and defaults it to true.