Question

Magneto 2 "Please use the 2fa provider-specific endpoints to obtain a token" error


Userlevel 1

Hi,
I want to connect our magento 2 store. I created an admin user with 2FA on the magento side, but when I try to connect I see the following error-message.

 

authentication failed: The app returned "Please use the 2fa provider-specific endpoints to obtain a token.".

 

Any idea what I did wrong?

 

cheers,

ToM


5 replies

Userlevel 7
Badge +11

Hi @Eisbaer, welcome to the Community! 👋
 

I did some looking into that error and found an internal note that suggested changing the settings for 2FA in Magento to fix the error.

Can you try changing the Enable 2FA for API Token Generation option to No:

c420aff57358ca54b5cc2c24eb37dc87.png
You should be able to find that option in Magento on the 2FA settings page (Admin > Stores > Settings > Configuration > Security > 2FA).

Can you give that a try and let us know if that fixes it?

@SamB 

The settings shown in your screenshot is not present in Magento2 - Is there a specific minor version of Magento2 you are referring to. I am having the same problem as @Eisbaer 

Userlevel 7
Badge +11

Hi @Anirudh! 👋

I did some digging and it seems that option isn’t available if you’re using Magento 2.4 or higher. But it should still be possible to disable it using the command line or by installing an extension that adds that missing option to the admin settings in Magento 2.4+.

You can read more about that on Stack Overflow here:
https://stackoverflow.com/questions/66831517/magento-2-4-2-how-to-disable-two-factor-authentication

Hope that helps! 🙂

Hi @SamB 

 

Thank you for the response. I did try that but that opens up another challenge as Zapier throws different error asking to setup 2FA before connecting. 

I had to skip this integration and directly integrate the other app (i.e. FB leads ads) with MySQL. It’s a workaround and not a solution but something as we business we can live with. 

Hope that helps someone else looking at this thread. 

Userlevel 7
Badge +11

I’m sorry to hear that didn’t work as hoped, @Anirudh. Really glad you were able to come up with a workaround though! Thanks so much for sharing details of that here. I’m sure there are plenty of folks in Community that will benefit from trying that approach too! 

Seems like you’re all set for the moment with that workaround, but if we can help with anything else at all please do reach back out to the Community - we’re always here for you! 🤗

Reply