Best answer

Looping do not split results

  • 1 August 2022
  • 1 reply
  • 76 views

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Hi,

I’ve iterated a lot of things before posting so I can assure you it has became a nightmare !

I have a “Find Many spreadsheet rows” action that produces multiple results. Those results must be processed individually through a number of actions so I used the “Looping” action by Zapier.

However, when processing the final step (ie Sending an email), it doesn’t “split” each row’s result into a separate email even though it sends the proper amount of emails (Loop iteration is correct)

Please find below my setup of the looping action.

The email is sent twice with all the above data inside. I’ve tried Line Itemizer Utilities before the loop, after the loop it doesn’t change anything. Zapier doesn’t take each row individually.

Thank you for your help !

Best, Y

icon

Best answer by Danvers 2 August 2022, 12:29

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +12

Hi @Yanovski!

From what I can see, you’ve set up the Looping action correctly so I suspect the issue lies with the email step. 

What fields are you adding in the body of the email? You need to use the name of the value rather than the ‘Preview loop values’ fields:

 

So, for your Zap you’d need make sure that you use the 1ER JOUR, PRODUCTUER, etc fields. Give that a go and let me know how you get on!