Linking to SmartSurvey

  • 12 January 2023
  • 3 replies

Firstly - no technical knowledge, I’ve trawled Google and here but have reached the end of my capabilities.

I’m trying to re-link a zap to Smart Survey, it’s worked for years but suddenly stopped.
Zapier says that the Smart Survey account is out of date, it’s not, as far as I know.  I have re-entered the username and password for SS but get an error message saying authentication failed, ensure your API token and token secret are correct.
I’ve checked SS and there is an active API set up for Zapier and the survey I’m trying to connect to has all the permissions allowed to share the results, but I still get the same error message in Zapier.
Any suggestions (in very easy layman’s terms please).  Thank you

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +12

Hi @Miller R!

It sounds like you’ve taken some great problem shooting steps, even if it didn’t find your answer, I love to see it! 🙌🏻

I took a look at our notes on SmartSurvey and it looks like you’ll need to use your API key and API token in the Username and Password fields respectively. 

We’re working with SmartSurvey to make this clearer when you connect your SmartSurvey account to Zapier. 


If you try that and are still having problems, it’ll be best to get in touch with the Zapier Support Team as they can take a look at the logs of the Zap when it tries to connect to SmartSurvey. You can contact them using the Get Help form, and if you do be sure to tell them what you’ve already tried so they know where to start from. 



that’s great, thank you, I’ll give it a go


Userlevel 7
Badge +11

Hi @Miller R! 👋

Have you been able to connect to your SmartSurvey account using Danvers’ suggestion yet? Want to make sure you’re all set here!