Best answer

LinkedIn Lead Gen Form error: We're having trouble loading 'Event' data. Internal Server Error

Hello, when I try to retrieve the data for an event registration with the LinkedIn Lead Gen form, I get the message ‘We're having trouble loading 'Event' data. Internal Server Error’. Will this solve itself in time or is there something else going on?


Best answer by Danvers 19 October 2022, 12:42

View original

12 replies

Userlevel 4

Hi @Marleen Cramer , 

I did some digging and it looks like that error is usually a permissions problem. Basically, you may not have access to see those events in LinkedIn. We have a help document that should get you started on double checking that:

On the other hand, if you do have the right permissions and it’s still not working, let me know! I’ll see what else I can dig up here. 

Hi @ClintEmsley,

Thanks for your answer. I have the right permissions, it’s working for multiple other zaps correctly. 

I hope you can dig something up! 

Userlevel 7
Badge +8

@Marleen Cramer checking back in here to see if you were able to pull your event registration data.

If not, I’d suggest reaching out to our friends in Support who can dig deeper and determine what’s going on. You can contact them here! @ClintEmsley if you’ve found something on your end just let us know!

I have the exact same issue, did you find a resolution?

@Liz_Roberts i just checked again, and I’m still unable to pull the data. I’ll contact support for this issue. 

@James Watson no, not yet.

Userlevel 7
Badge +12

Hey everyone 👋🏻

I have some follow up on this issue. 

First of all, if you are having a similar issue the first thing to do is to check that you have the required permissions. You can find more details on that in this help guide: Common Problems with LinkedIn Lead Gen Forms


If you have tried that and it’s still not working then you may be running into a known issue where events aren’t correctly loading. If you’ve checked your permissions and still aren’t seeing your events, there is a workaround that you can use. 

When you are setting up the trigger step, click on Event then click Custom copy and paste the LinkedIn Event ID 


You can find the LinkedIn Event ID in the url of the event: ID/about/


I hope that helps anyone who’s running into the same problem!

Why are you posting screen with “Custom” that doesn’t allow to enter any data?

Isn’t this why we have this thread in the first place? That doesn’t sort the problem @Danvers 


By the way I have the same issue and its super annoying must say. No clear message why I can’t type Event ID

Userlevel 7
Badge +9

Thanks for reaching, @Lukasz1! We should be able to paste the Event ID in this field here:

I know a workaround isn’t always ideal but hopefully this gets you up and running. Keep us posted!

I too now am having the problem that is described in this chain - I have been using Zapier for a couple of years, and this is the first time it has caused this problem of not being able to recognize an event that I established on LinkedIn a few hours before. 

It really looks like a server is down, as I have relogged in and re-established my LinkedIn account on Zapier.  

Any suggestions?



Userlevel 7
Badge +11

Hi @TanyaH!

Have you tried using the workaround proposed above? I know it’s not a fix but it could at least get you up and running :)

I suspect if a server were down we’d be seeing more reports about it in the Community and in our Support queue, but I’m not seeing that.

@nicksimard - I did try to Custom workaround above, but Zapier does not recognize anything I am putting into the field.  

For example, I have tried

and all that Zapier says to either is 

Unable to pull event registration form responses

Please reload the page. If the issue persists, troubleshoot error or contact Support.

Error code: Error while retrieving: No virtual resource found

So, I am stil stuck.  I just sent in a ticket - I hope I can figure out what is going on and fix it sometime soon! 

Userlevel 7
Badge +11

Hi @TanyaH! 👋

Thought I’d hop in here for Nick to see if I can help. For the event ID it would expect it to be a number not a URL. The event urls should contain the ID number within them though.

For example, for this url, the event ID would be 12345287236.

Can you try using just the number from your event URLs and see if that gets it working?

Keen to ensure you’re all set here so please let us know how it goes!