Best answer

Jotform to Xero: Unable to link Quantity field from form to calculate invoice amount.

  • 17 March 2023
  • 5 replies
  • 44 views

I am trying to connect my Jotform to Xero to create an invoice. We’ve set up the item code etc in Xero and linked this through the to Zapier form. When it comes to the Quantity I want to connect the number of attendees input on the form, to then calculate the amount on the Xero invoice. But I can see the filed code in Xero.

 

Jotform …

 

 

Zapier connection - doesn't show this field name….

 

 

 

What am I getting wrong here? I am taking it the quantity amount will then multiple by the item code set up in Xero - which will then publish the invoice.

 

icon

Best answer by Learning MATTERS 17 March 2023, 05:32

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Learning MATTERS 

Good question.

Did you try submitting the Jotform, then pulling thru that example in the Zap trigger to use to configure the Zap?

How to change the Zap trigger test data: https://help.zapier.com/hc/en-us/articles/8496310366093

 

JotForm values are missing or incorrect

 

There are several settings that can cause your JotForm values to appear incorrect or not appear at all. Please check the following settings:

Europe datacenter

If you see blank values or values like “N/A” and your JotForm account is not based in the United States, you may need to change your JotForm settings.

  • In JotForm, go to your data settings.
  • Clear the Europe Datacenter field.
  • In Zapier, go to My Apps.
  • Click Add connection.
  • Search for and select JotForm.
  • In the dialog box, select No for the Do you use European datacenters field.

HIPAA compliance

If your JotForm account has HIPAA compliance enabled, Zapier won’t receive values for any protected fields.

If you don’t need HIPAA-compliant forms, you can disable that feature:

  • In JotForm, go to your data settings.
  • Click Disable HIPAA Compliance
  • In Zapier, go to My Apps.
  • Click Add connection.
  • Search for and select JotForm.
  • In the dialog box, select No for the Account HIPAA compliant? field.

Form settings

If you see long alphanumeric strings instead of your form values, you’ll need to disable the Encrypt Form Data setting.

  • In your form, click Settings.
  • In the left sidebar, click Form settings.
  • In the Encrypt Form Data field, select No.

Thanks - I can now see all my new filed forms, but I am still unsure what needs to go in the Quantity column?

I have coded the item through xero and connected this. Surely the quantity would need to be the amount of items. I have selected a number field which the form filler will determine, but it’s not working when I test the zap. Please can you advise.

Yes - I have filled the form out and used that to configure the zap. I have also checked all the settings described.

Userlevel 7
Badge +6

Hey @Learning MATTERS,

Thanks for letting us know!

Before we dig deeper into this, you mentioned that you want to map the “How many (total) attendees” from the trigger to the “Quantity” field in Xero. Is that right? If so, could you please send a screenshot of the trigger data for us to check if the field is returning the data (Please exclude any personal information on the screenshot).

 

Thanks for getting back to me. I think I may have sorted it. The default Quantity on my form was set to 0, and so I have now set it to 1 and it has pushed through the test without any trouble. Plus is showing the cost.

 

Yay!