Question

Issues with complex Zap using loops, digest, and filters for blog post creation.

  • 16 November 2023
  • 2 replies
  • 44 views

 I am trying to create a pretty complex zap using loops to generate sections of a complex blog post which im having written section at a time, added to digest, and then after a filter, relased to WP.

 

I’ve tried this with paths and was getting poor results for various reasons (path a was last iteration, B first iteration, and path C any sections beween 2 and second to last section. As you can see, that kept not running right. 


So anyways i took away the paths and combined paths b and c and just added a filter to only pass on to last steps on final run of the loop.

That final run should be  = to the number of sections i have. This would not be the first section or =1. Since these are more complex posts, I anticipate there will be at least 2 secitoins, so therefor the iteration shouldnt be = to 2 either. And just as balance I know the number of Count in DIgest will go up as sections are added, so i made “count must = total sectons”.

 

**please note #21 is actually “FInd digest”, not append digest

 

 

The arrow is covering it up, but it says Loop Iteration start at 1. 

Latest results in the zap ending due to filtering.

 

 

 

I still cant understand what is going wrong, but perhaps im misunderstanding how to use the Looping function correctly. Can anyone please assist?

 


2 replies

I must have burned 1500 tasks triyng to solve this issue and support has been busy so i get delayed responses.

Userlevel 7
Badge +6

Hi there @GSIAlex,

It looks like your ticket with our Support Team is being attended to. I’d recommend continuing the conversation with our Support Team via email since they have the correct tools to dig deeper into the Zap and its logs to determine the cause of the issue.

I appreciate your understanding.

Reply