Question

Issue updating Ecwid product description

  • 13 June 2024
  • 1 reply
  • 7 views

I don't know if Zapier maintains the Ecwid app or if Lightspeed does.  Either way, I discovered a bug.

Products cannot be updated with the "Update Products in Ecwid by Lightspeed" action.  

To reproduce: 

1) Trigger: "New Products in Ecwid by Lightspeed"
2) Use GPT to gen a description
3) Use "Update Product in Ecwid by Lightspeed" to save the description back to the Ecwid product listing

Test result message: Failed to create a product in Ecwid by Lightspeed
The app returned "403".

- Note we are not trying to "create a product", we are trying to "update a product".  So there is a bug.
- I am the owner of the Ecwid account with full permissions.
- I tested the connection (also, I can retrieve products, so the connection is fine).
- I'm using the correct Product ID
- I have tested with - and without - the "p" modifier for the product ID
- I have tested with multiple browsers.
- The product exists in the Eciwd account (retrieved in the first step)

UPDATE:

- I’m using the latest version of the Ecwid by Lightspeed app.​​​​​​​
When I created a new step using the previous version of the Ecwid by Lightspeed app (1.3.4), it works fine. Looks like it’s an issue with the latest version.


1 reply

Userlevel 7
Badge +6

Hi there @ext237,

Welcome to the Community! 🎉

I suggest sharing this information with our Support Team so that they can create a bug report on your behalf. You can also relay this to Ecwid by Lightspeed’s developers, as they are the ones who update and maintain their integration in Zapier.

Hopefully, this helps!

Reply