invalid token error in GPT

  • 13 December 2023
  • 5 replies

Userlevel 1

Hi, I'm getting this error from GPT. Everything is setup and tested in Zapier. let me know if you need any further details of my accounts/setup. I tried deleting everything and starting from scratch, re-authenticate everything, but the issue persists.


[debug] Calling HTTP endpoint

"domain": "",
"method": "get",
"path": "/gpt/api/v1/available/",
"operation": "list_available_actions",
"operation_hash": "755f92d9ceb821686e13ba1617b2398698859d18",
"is_consequential": false,
"params": {}

[debug] Response received

"response_data": {
"error": "invalid_token"
"status_code": 401,
"action_id": "g-590c88c950b956b02f2022b13310573267ce871d"

Error talking to

It seems there is an issue with the Zapier AI Actions tool, as the outbound call did not succeed due to an invalid token. To proceed with sending an email, you will need to ensure that you are logged in to Zapier’s AI Actions and have the necessary actions enabled.

If you haven't already configured the required action for sending emails, please use this configuration link to set up the Gmail: Send Email action. Once you have done this, let me know so we can continue with your request.


5 replies

Userlevel 7
Badge +11

Hi @MikeT! 👋 

Thanks for surfacing this and for sharing details of the troubleshooting steps you’ve taken so far. As AI actions is an Alpha product and still being developed it’s likely that this could well be a bug. Us folks here in the Community aren’t able to access the logs so I think it would be best to contact the Zapier AI support team about this, which I can see you’ve already done - which is great! They’ll be the best folks to speak to on this as they can investigate the logs and open a bug report for this as necessary so we can track the impact this is having on folks which will help to prioritise a fix.  

Sorry to not have an immediate solution or workaround to suggest right now. Please do keep us updated on how you get on with them!

Userlevel 1

I encountered the same error of Invalid Token 401, and I took a few hours to finally resolve the error.

The solution is not very obvious. Basically, it involves logging out and logging back in again.


Step by Step

On GPTs, Click on “Privacy Settings” (yes… you read it right…)
Under “Connected Accounts”, Logout/Login
Follow the Instruction to allow access for OpenAI, & it works now



Userlevel 7
Badge +11

This is awesome news! Thanks so much for following up here to share details of the solution you found @Lawrenceteo. Really appreciate you taking the time to share this with the community! 🤗

@MikeT - can you give Lawrenceteo’s solution here a try and let us know how you get on? Would love to know whether that solves things for you too! 🤞

I have the same problem and the answer of @Lawrenceteo did not work.

Userlevel 7
Badge +11

Hello there, @Beepstream

Sorry to hear that solution didn’t work for you. I spotted that you recently posted a similar topic which I’ve since responded to:

I suspect that both errors actually might be one in the same so can you please give the suggestions I mentioned in my other reply a try just let me know how you get on - in that other thread. Suggesting to respond in the other thread so it’ll be easier to keep track of our conversation in a single thread rather than two.

Thanks! 🙂