Best answer

Internal Server error

  • 4 November 2022
  • 2 replies

Since yesterday I am experiencing an “internal service error” when I try to create a new zap. Anyone else? 


Best answer by Danvers 9 November 2022, 10:01

View original

2 replies

Userlevel 7
Badge +12

Hi @selina diemar!

From what you’ve described, that’s not an issue that we’re currently experiencing on Zapier. Could you share a screenshot of where you are seeing that error? That will help us to better understand what you’re seeing. Don’t forget to remove or obscure any personal or private information in any screenshot you share in the community (eg full name, email address, etc).

Userlevel 7
Badge +12

Hi @selina diemar!

I can see that you reached out to our Support Team about this and you were seeing this error when loading Events using the New Event Registration Form Response in LinkedIn Lead Gen Forms trigger. 

In case you didn’t see the response from our team or if anyone else is running into the same issue, here’s what they replied:

It either indicates a permissions issue, or you may be running into an open bug. 
To use this trigger on Zapier, please ensure that you have the correct permissions as per these two guides:
How to Get Started with LinkedIn Lead Gen Forms on Zapier
Collect leads from LinkedIn Events with Zapier

To use this app and particular trigger with Zapier:

  • The connected user must be either a super admin or content admin of a company page. Read more about LinkedIn Company Page permissions.
  • Your event must be public and have the registration form enabled.
  • If you’ve previously used LinkedIn Lead Gen Forms for Ads, you will need to reconnect before creating a LinkedIn Events form Zap, as the trigger uses a different API.

You can find more details about how to set up an event registration form on LinkedIn's help center

Assuming that you have all the right permissions, if the Events are still not loading, it may be that you're running into a bug that results in events missing from the dropdown (alongside the server error).
(Please do check on the Company Page Admin or Lead Gen Forms Manager role to ensure you have all the right permissions.) 
Assuming that it's the open bug at play here, we do have a workaround to select the Event using a Custom value.

First, please locate the link to the event itself. For instance, this could look like this:


Then Open the link > right-click > View page source > and look for (CMD+F) professionalEvent:. Here's a screenshot.

Once you've located that ID after the event, you can paste that into the Zap as a custom value like so:

(Click here to view larger)

If it is a permission issue (and the Event(s) showed up after changing permissions/reconnecting the account) or if you had to apply the workaround and if that worked that means it could be a known issue with the Linkedin Lead Gen Forms integration. If that’s the case, please get in touch with the Support Team to let them know so they can add you as an affected user on the issue.