Question

Information missing from Facebook Lead Ads


 We’re experiencing an issue on several zaps that link Facebook Instant Forms to Gmail. 

We use Zapier to notify us via gmail when a facebook lead has been submitted, and then pass that info on to a client management platform and Mailchimp. For the most part everything works as intended, however on maybe 10% of leads some information from the Facebook form will be missing from the email. On those leads, they also do not import properly into our cms. 

 

  This is what the zap is set up to pass on. 

This is what the zap is set up to pass on, and for the most part the emails we receive look identical to this. ​

However some of the emails come through like this, missing the campaign and ad name.

 

What could be causing Facebook to omit this information? Is there are step we can take to correct this?


2 replies

Userlevel 7
Badge +14

Hi @DelRicht Research 

Check your Zap Runs history details to see the DATA IN/OUT for each step to help you troubleshoot.

Help articles for using FB Lead Ads in Zaps that may provide guidance: https://zapier.com/apps/facebook-lead-ads/help

Userlevel 7
Badge +11

Hi there @DelRicht Research 👋

I know it’s been a while since you first reached out here so you might have already got this solved but in case you haven’t, I wanted to share that this can sometimes happen when there’s a difference between the fields that are selected in the Zap and those that are sent when the Zap runs.
 

You mentioned that for 10% of the leads some of the information is missing so I’m guessing that the Zap is set up to trigger for all forms rather than a specific form, right?

If that’s the case, then you’ll want to select a specific form in the Zap’s trigger instead. As it’s likely that not all your Facebook Lead Ads forms have the exact same fields. 

So for each of your Facebook Lead Ads forms you’d set up a separate Zap. The quickest way to do that would be to: 

That should ensure that the Zaps use the correct form fields when they run so that the information isn’t missing in those emails. 

Hope that helps. If that doesn’t work or you found a different solution please let us know, would love to hear from you! 🙂

Reply