Incorrect Custom Field IDs Synced from ClickUp to Google Sheets via Zapier

  • 10 May 2024
  • 1 reply

Userlevel 1

Hi there,

I previously set up some automations between ClickUp and Google Sheets. For my graphic design agency I have different type of projects. I categorize these by using a custom field in ClickUp.

These custom fields has different options, all of which have a specific ID. This ID was previously synced to my google sheet. 

I then used the v-lookup function in Google Sheets to categorize all of my projects with the right tags. This all worked just fine the previous months

For example, this subtask called '’Intake of information'’ has this specific ID 

Somehow my zap doesn't synchronize the right ID anymore. All IDs are the same now and it's not even categorized as a custom field so I'm not sure where the issue is coming from.

​​​​​​I tried looking at my zap history but apparently I have to update my subscription whilst I'm already on a subscription of 60 USD per month?

Furthermore, I do know the data is still available, as I actually looked for the tag ID in my zap history and it's still there: 
I'm pretty sure my set-up is the same as it was previous month, unfortunately unable to check that though:

Take note that the 786b … 928 numeric value is the value which I don't recognize and is not associated to any tags

When I try searching for the specific ID I do get a few hits, but these are long lists of all IDs that ever existed:
I am kind of stuck at the moment. Would anyone have a fix for this?


1 reply

Userlevel 7
Badge +11

Hi @MischaDR99! 👋

Hmm, if it was working previously then something may have changed on ClickUp’s end. It looks like the name of the field in the Zap History differs to the one selected in the Zap:

I say that because with the id field nested like that I’d expect the field in the Zap to appear more like Task Custom Fields Sort of Project Type Config Options ID rather than Task Custom Fields Sort of Project Id.

So I wonder if a change to the structure of the fields has caused the Zap to not be able to reference the correct field. Do you think that could be the case here?

Can you try pulling in a new test record in the Zap to see if that pulls in field names that match what’s present in the recent runs in the Zap History? 

Looking forward to hearing from you!