Best answer

I'm getting an "Error 403 Forbidden" when connecting Woocommerce to my Zap.

  • 31 May 2022
  • 8 replies
  • 2423 views

Hey my site is https://azreselling.shop and I’m trying to do a zap for my woocommerce & discord.

 

Connecting my discord is no problem but when I try to do woocommerce I just can’t, it keeps saying 403 Forbidden but I know that the account I’m using is the owner of the entire site, I’m using the application password I made too.

 

Not sure on what I’m doing wrong, do I have to put the wordpress email / username instead of my login to my site? 

icon

Best answer by christina.d 17 June 2022, 05:52

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @Aizyy 

Good question.

Getting Invalid Webhook URL error when plugging the webhook into WooCommerce

If you're seeing this error when pasting the webhook into WooCommerce, this means that you aren't on the latest version of the WooCommerce Zapier plugin. You have two options for how to move forward:

  1. Upgrade to the latest version of the WooCommerce Zapier plugin.
  2. Use a different format for your webhook. So instead of https://hooks.zapier.com/hooks/catch/12345/abcde/ you can use https://zapier.com/hooks/catch/12345/abcde/. This should allow you to pass the validation check on the WooCommerce side and should still work.

 

I have a different problem/error

WooCommerce provides detailed documentation on known common problems.

I'm still having problems!

If you're having troubles with your WooCommerce installation, please submit a ticket to the WooCommerce team

If you're having troubles with the WooCommerce Zap, please send us a support ticket using this form

Userlevel 7
Badge +9

Hey @Aizyy! It looks like you have been in touch with our support team who was able to locate the issue:

I did some digging in our logs on the error when you attempted to connect to WooCommerce. I'm seeing the following response from WooCommerce. That response is truncated, but you will see some useful details here. It looks like WooCommerce is saying:

Attention Required! | Cloudflare...

...Please enable cookies.
...You are unable to access azreselling.shop

..Why have I been blocked? This website is using a security service to protect itself from online attacks. The action you just performed triggered the security solution. There are several actions that could trigger this block including submitting a certain word or phrase, a SQL command or malformed data. What can I do to resolve this? You can email the site owner to let them know you were blocked. Please include what you were doing when this page came up and the Cloudflare Ray ID found at the bottom of this page. Cloudflare Ray ID: 7143532b2dcc81b7 ...

 For this issue, please review WooCommerce's authentication errors. It looks like there is one specifically for cloudflare errors that may help: https://docs.om4.io/woocommerce-zapier/troubleshooting/#authentication-errors
 

If you run into further issues for this specific error, feel free to reply to your support ticket and our team can continue to lend a hand!

Hey @Aizyy! It looks like you have been in touch with our support team who was able to locate the issue:

I did some digging in our logs on the error when you attempted to connect to WooCommerce. I'm seeing the following response from WooCommerce. That response is truncated, but you will see some useful details here. It looks like WooCommerce is saying:

Attention Required! | Cloudflare...

...Please enable cookies.
...You are unable to access azreselling.shop

..Why have I been blocked? This website is using a security service to protect itself from online attacks. The action you just performed triggered the security solution. There are several actions that could trigger this block including submitting a certain word or phrase, a SQL command or malformed data. What can I do to resolve this? You can email the site owner to let them know you were blocked. Please include what you were doing when this page came up and the Cloudflare Ray ID found at the bottom of this page. Cloudflare Ray ID: 7143532b2dcc81b7 ...

 For this issue, please review WooCommerce's authentication errors. It looks like there is one specifically for cloudflare errors that may help: https://docs.om4.io/woocommerce-zapier/troubleshooting/#authentication-errors
 

If you run into further issues for this specific error, feel free to reply to your support ticket and our team can continue to lend a hand!

I’ve disabled some cloudflare things but now it’s coming up with ANOTHER Error, I’ve sent a few tickets to the zapier team but I’ve got no answe so I figured out I’ll reply here.

 

The error is 503: Service Unavailable, it’s getting really annoying at this point since I paid for something that don’t even work with support answers that take 1+ Days

Userlevel 7
Badge +12

Hi @Aizyy

I’m sorry that you’re still having trouble connecting to WooCommerce. I can see that the Support Team replied to you shortly after your last post here - have you received that email?  Thanks!

Hi @Aizyy

I’m sorry that you’re still having trouble connecting to WooCommerce. I can see that the Support Team replied to you shortly after your last post here - have you received that email?  Thanks!

No, my ticket ID is 25741

Userlevel 7
Badge +9

Hey there, @Aizyy! I can see the last reply they made was Sunday. This was their reply.

Can you share the Website URL you're using when creating your WooCommerce connection here:
 
2e08a793de835184f5f682032f647028.png
(view larger)
 
Is the error you're getting on this step the same as shown in this screenshot:
 
4820b4f9383f7ecdc71d4d0805ec1b1c.png
(view larger)
 
If so, can you try the following in your Website URL field:
 
https://www.azreselling.shop/guide/

 

If you're not seeing it, I might recommend checking your spam/junk folder in case it’s ended up there by mistake. If it's not there I recommend searching your whole email inbox for emails ending in ‘@zapier.com’. Hope that helps! 

https://community.zapier.com/tips-and-inspiration-5/are-you-having-trouble-receiving-emails-from-zapier-842
 

Userlevel 7
Badge +12

Hi @Aizyy! I can see that you were able to find our reply to your ticket and have responded to let us know that you fixed the issue, awesome work 🙌🏻

I hope you don’t mind me sharing what you found here so that other folks can find it if they need to. 

This was how you able to fix the 503: Service Unavailable error

I checked my .htcaccess file and looked for rules related with " RewriteRule " & " RewriteCond " I figured out which rules were out of place, I simply added a # to the one I thought that shouldn't be there, and it fixed my issue, my site is working completely fine including any plugin inside.

The rule I nulled was " # RewriteRule ^(.*)$ http://www.azreselling.shop/$1 [L,R=301] "

Userlevel 7
Badge +9

Hey friends! I wanted to summarize some of the responses the support team dug up for as well as some follow-up troubleshooting from the OP. 🤗

I did some digging in our logs on the error when you attempted to connect to WooCommerce. I'm seeing the following response from WooCommerce. That response is truncated, but you will see some useful details here. It looks like WooCommerce is saying:

Attention Required! | Cloudflare...

...Please enable cookies.
...You are unable to access azreselling.shop

..Why have I been blocked? This website is using a security service to protect itself from online attacks. The action you just performed triggered the security solution. There are several actions that could trigger this block including submitting a certain word or phrase, a SQL command or malformed data. What can I do to resolve this? You can email the site owner to let them know you were blocked. Please include what you were doing when this page came up and the Cloudflare Ray ID found at the bottom of this page. Cloudflare Ray ID: 7143532b2dcc81b7 ...

 For this issue, please review WooCommerce's authentication errors. It looks like there is one specifically for cloudflare errors that may help: https://docs.om4.io/woocommerce-zapier/troubleshooting/#authentication-errors
 

 

Following this the OP did run into a 503: Service Unavailable error though.

They were able to resolve this by:

...checked my .htcaccess file and looked for rules related with " RewriteRule " & " RewriteCond " I figured out which rules were out of place, I simply added a # to the one I thought that shouldn't be there, and it fixed my issue, my site is working completely fine including any plugin inside.The rule I nulled was " # RewriteRule ^(.*)$ http://www.azreselling.shop/$1 [L,R=301] "

 

I hope this helps!