Best answer

Hubspot to Google My Business - Status Code 400 Bad Request

  • 7 December 2022
  • 8 replies
  • 211 views

Hi,

I have read through the other posts on GMB but was unable to find a solution.  

I have a small estate agency (providing a service) with a single location on GMB.  I can connect with Zapier and complete the Location (required) field when trying to set up a zap.  My aim is to create a post when a deal in Hubspot reaches a certain Stage.  I keep getting an error.  

The Deal should Trigger the Action.  The Action is not working.

Status Code 400 Bad Request

Last updated: 3 years ago

Problem

Your Zap is likely to be missing a required field, or a field value wasn't in a recognized format. For example, if a field in your action step is expecting an email address, but the value given is a name, the app may return a 400 error.

Solution

Check that your fields are correctly set up and mapped to each other.

 

After some digging on the forum, I see most people are having issues with their locations and the ownership of those locations.  I have just one location (that is showing in the drop down on the Trigger) and I have no idea how to change the ownership of that location (might be a feature when you have 2 or more).  

If anyone has help, please let me know?

Thank you

icon

Best answer by morneip 13 December 2022, 07:49

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +12

Hi @morneip!

I’m sorry that you’re having trouble with your Zap. Could you share a screenshot of the Google My Business step in the Zap editor so we can see how it’s set up (what information is in the different fields)? Don’t forget to remove or obscure any personal or private information in any screenshot you share in the community (eg full name, email address, etc).

If we can see the step we’ll be able to better understand what might be happening.  Thanks!

Trigger setup
Action setup

Hi @Danvers thank you for the help.  Is this enough information?  

Userlevel 7
Badge +8

Hi @morneip ! Checking back in to see if you were able to crack this one.

If not, try checking your “Erf Size” field- I wonder if tweaking the format and/or using test data with a value in this field would do the trick. 

Let us know if you are still running into trouble here!

 

Hi @Liz_Roberts , thank you for the guidance.  Unfortuantely I have not cracked it.  I tried your suggestion, sadly without success.  I just cannot see what I’m missing and there aren’t many things to change.  

Userlevel 7
Badge +8

@morneip - thanks for giving that a whirl. 🤔

@MohSwellam @Todd Harper do either of you see something we’re missing with the mapping here? 

Userlevel 7
Badge +8

Hi @Liz_Roberts 

 

I would say it’s the Location field as @morneip suggested. When connecting your GMB account, did you allow the last option for See, Edit, Create and Delete you Google business listings ? It seems its not a required field in the authorization but I think its an important one. 

 

Userlevel 6
Badge +8

@MohSwellam’s guess is mine as well.

Let us know if that works for you, @morneip! (You may need to reset your connection to your GMB account to access this authorization window again.)

Hi @Todd Harper and @MohSwellam

Thank you for your help.  I went ahead and changed all the Google account connections on both Zapier and Google side. 

This was my original setting on Zapier which shows when you simply test the connection/reconnect in Zapier
I changed it, ensuring the box was selected when I connected the accounts again. 

 

This was not the solution in my case.  

The culprit was the URL for the photo.  I removed the url and the post went through.  The image is on Google Photos and I guess it should be a url pointing to an image in a repository.

Thank you for your time trying to help me, I wish you all the best.