HubSpot Error: Property "propertiestoretrievenote" does not exist

  • 10 October 2023
  • 11 replies

Hello everyone,

I am struggling a bit with, what would seem to be a straightforward automation.

I have a spreadsheet in Google Sheets where I keep track of all my clients and use that to keep them up to date.

I created an automation in HubSpot that creates a contact every time a new row to the sheet is added. After that it creates a deal.

I have a column in my sheet that I use to update the deal progress and I want it to also automatically change the deal progress in HubSpot.

When I made the automation I received the following error:

Property values were not valid: [{"isValid":false,"message":"Property \"properties_to_retrieve_note\" does not exist","error":"PROPERTY_DOESNT_EXIST","name":"properties_to_retrieve_note","localizedErrorMessage":"Property \"properties_to_retrieve_note\" doe

I checked if I named the deals in my spreadsheet correctly (not using the names in the Pipeline, but the ones that HS displays - the deal IDs) and checked for Typos and everything looks fine.

Tried the AI but it was no help at all.


Am I going about this the correct way at all? And if I am, how can I get the google sheet column to connect to the deal stage?


Thank you!

11 replies

Userlevel 7
Badge +14

Hi @Eri 

Good question.

It’s likely the HubSpot field you are trying to use is a dropdown list of options.

In the Zap editor, open the dropdown list to the see the options.

Each option has 2 values. (top/bottom)

The bottom value for each option is the value HubSpot expects.

So you may need to translate the values from your GSheet to what HubSpot expects.

Thank you for your reply, @Troy Tessalone 


These are the values provided by HS:

I have set-up my Spreadsheet to use the grey text:



Unfortunately, even with this set-up I get the same error when I try to test it:


I have also tried using the bold text, but get the same error.


I have checked for typos and even went as far as copy/paste the deal IDs from HS into my Spreadsheet, but nothing changes - I get the same error every time.

Userlevel 7
Badge +14


The error may be related to a different field and how it is configured.

@Troy Tessalone 


All the previous steps were completed without an issue. In this one, I have only two things - the deal ID, which I get from a previous action and the Deal Stage that I am trying to update.


I also manually checked the deal ID to make sure it is the right one.


I guess I will have to look for another way to automate this,



Userlevel 7
Badge +14


We would need to see full screenshots with how your Zap steps are configured to have enough context.

@Troy Tessalone 


Apologies for the late reply:


Here is the full automation.


This is the trigger:



First Action:

Second Action:



Third Action (which I am not sure I even need)



And the last one:



Userlevel 7
Badge +14


You only need step 4 is values from step 4 are mapped to following action steps.


Check to make sure the Deal Pipeline and Deal Stage are valid combos.


Look at the Properties to Retrieve section.

Can you post screenshots with how HubSpot step 5 is configured at the bottom of the Action section?


Can you provide the full error message?


@Troy Tessalone 


The ID and properties were correct, but for some reason it still was not working. What I ended up doing is deleting the whole Zap and creating it a new with the same settings and somehow it worked.


After that I reworked it using HS Associations for better results and Zapier Formatter and it is running as intended.


Should I post the final automation here in case someone else needs it?

Userlevel 7
Badge +14


It’s encouraged to share your solutions so others can learn and benefit, thanks.

@Troy Tessalone 


Those are the steps that I took:



Action 1:


Find Contact in HubSpot:


Action 2: Find Associations in HS: - locates the deals for the contract that we found with Action 1



Action 3: Formatter by Zapier - If there is more than 1 deal associated with the contact



Action 4: Update Deal in HS using the Formatter from Action 3:



Userlevel 7
Badge +14


Can you provide the full error message?