Best answer

How to pull an email address from Facebook Lead form through to Mailchimp

  • 29 March 2023
  • 5 replies

I can’t seem to find the dynamic value to pull in an email address from a Facebook lead form.  There doesn’t seem to be any value available for me to pull in - and when I type manually ‘EMAIL’ or something like that it doesn’t recognise it.




Best answer by moliver3 29 March 2023, 17:34

View original

5 replies

Userlevel 7
Badge +6

Hi there @moliver3,

It looks like the Facebook Lead Ads trigger is using a “fallback” sample data. 

In some cases, issues that come up while testing the Zap are caused by the trigger providing “fallback” sample data, which will not necessarily line up with the unique data that you’ll be seeing in a real-world scenario.

The best way to see how to map incoming data, and how your real data will be handled by the Zap, is to submit your own test data and import it as new sample data in the Zap’s trigger. ​To do this, you’ll want to follow the steps below:

  1. Open up the app that is sending information to Zapier. Create and submit a new test that should trigger the Zap.
  2. In a separate tab or window, open your Zap, and head to the “Test” step in your trigger. Select “Test Trigger”.
  3. The Zap will search for new samples, and if everything was connected properly, your new test should appear. If you don’t see what you’re looking for, select a sample by clicking the dropdown menu and select “Load More” to find even more samples.

This guide also goes into more detail about setting up your Zap’s trigger, and may be helpful:

Please give that a try, and let us know how it goes!

Thanks! 😊

Thanks but I know it is not connected up properly because I don’t have any idea what value to put in the email field.  I tried to follow your steps but I keep getting the same error message.   I don’t know how to force data in from FAcebook as it is from an ad and I can’t access it myself unless it is showing to me.  One person has subscribed already but that person’s data is not coming through.


Any thoughts please?



Update. Ok I’ve found where to test the form in Facebook and entered my own email address. Unfortunately it doesn’t resolve the situation as I still get the same error message when testing. I can’t find anything in the help files to guide me on what to do. I’ve looked about two hours now :-(


I deleted the Zap and started again.  It seems to be working now. Seems like you have to create the Zap after you’ve already started running the form?

Userlevel 4
Badge +6

Hi @moliver3

Great to hear you were able to get everything resolved. 😊

Sometimes we’ll just need to start or create a new Zap for the configuration to be refreshed.