Best answer

Google Sheets Zap isn't transferring hyperlinks, only text.

  • 10 June 2021
  • 4 replies

I have a Google Sheets data base that has an embedded link in one of the cells.  The trigger is set up so that when the link is added to that cell, it zaps that (and other information) to a third party.  Everything is going great but the hyperlink isn’t live. 


Example--let’s say I’m zapping over the word “potato” the word “potato” gets zapped but the URL behind the word does not.  How do I fix that?




Best answer by Matt Cromwell 10 November 2022, 16:03

View original

4 replies

Userlevel 4
Badge +9

Hey @Camp!

Thanks for the question! Unfortunately I don’t see that embedded links within the cell are pulled in from the New Row trigger, only the text contents of the cell is ☹️ I tried this out with a sample in my own account. 

The only way to get that link would be to have the link as the contents of another cell in that row, then you would be able to map it into action steps of the Zap.

Hope that helps!

Userlevel 1

Google Sheets has a “HYPERLINK” function that will work. Just enter it like this in your Zap:


Userlevel 1

Matt’s solution worked perfectly for me with Excel

Userlevel 7
Badge +11

Thanks so much for letting us know, @AccountingStaff. Really glad that approach works with Excel too! 😁