Best answer

Google Sheets “There was an error writing to your Google sheet. Unable to parse range” error

  • 12 October 2021
  • 9 replies

Can anyone help me figure out how to fix this issue? Attached are the screenshots for reference. Thanks!


Best answer by SamB 22 March 2022, 12:32

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +14

Hi @Podcast Elevator 

Please post screenshots with how your Zap step is configured, thanks.


Also, check out the available help articles:

Userlevel 7
Badge +9

Hi @Podcast Elevator 

Can you share another screenshot showing how you configured that step? It looks like either an issue with your connection or configuration, you may try reconnecting your account or using a different gmail/google account.


@Troy Tessalone 




I had changed the linked Gmail account. Still didn’t work.

Userlevel 7
Badge +11

Hey @Podcast Elevator, welcome to the Community! 

From the look of those screenshots it seems as though either the Spreadsheet or Worksheet name may have changed recently as it doesn’t match the name of where Zap is attempting to add the row to:

Can you try reselecting the Spreadsheet and Worksheet in the Zap and then retest to see if that then allows you to create the test row in Google Sheets? 

Hopefully that’ll do the trick! :)

Hi @SamB, thanks!

That's exactly what I thought as well when I saw the error message, but I already tried doing what you suggested and still come up with the same error message. Is there any other workaround on this?

Userlevel 7
Badge +11

Great minds think alike, @Podcast Elevator! ;)

Hmm, this is very odd indeed. After you reselected the spreadsheet and worksheet did the name on the error message then match the name correctly, or were were they still different? If you could send over a screenshot to confirm this so we can see the latest error that would be super helpful.

Also, are there any frozen columns or rows on the Google Sheet? If I remember correctly, that can sometimes cause trouble with updating rows. 

Userlevel 7
Badge +14

@Podcast Elevator 

FYI: Hidden columns and protected columns can cause issues as well.

Hey there,

I had this exact same issue, I have a lot of experience with Zapier but still couldn’t figure it out!

I deleted the entire step and re-created it. That seemed to work! 


Userlevel 7
Badge +11

It looks as though @Podcast Elevator was able to get past that error by refreshing the fields in the step and reselecting the spreadsheet and worksheet. This may not fix the issue for all cases though so I wanted to follow up here to summarize all the possible causes and solutions for anyone that’s having similar issues:

  • The spreadsheet or worksheet name changed since it was initially selected: Try refreshing the fields and reselecting the spreadsheet and worksheet.
  • The selected worksheet contains frozen/hidden/protected columns or rows: Try unfreezing/unhiding/unprotecting those columns/rows in the selected worksheet.
  • The connected Google Sheet account has insufficient permissions (read-only): Assign editor permissions and reconnect the Google Sheets account to ensure we’re using the updated permissions for the account.

We also have a guide on how to fix this sort of “There was an error writing to your Google sheet” error here: Google Sheets error: “There was an error writing to your Google sheet.”