Skip to main content
Question

Google Sheets error: The app returned error 400 Bad Request.

  • February 16, 2024
  • 1 reply
  • 38 views

I need to protect a worksheet that the Zap adds rows, etc. to so it is only viewable, and not editable. I keep receiving an error when the sheet is protected.

Is there a work-around?

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Troy Tessalone
Zapier Orchestrator & Solution Partner
Forum|alt.badge.img+14
  • Zapier Orchestrator & Solution Partner
  • February 16, 2024

Hi @mcerchiaro 

I believe the spreadsheet/worksheet/cells need to be accessible to be used in Zap steps.

 

Help: https://help.zapier.com/hc/en-us/articles/21637520631949-Google-Sheets-error-400-bad-request

 

Symptoms

You see a “400 Bad Request” error when Zapier tries to update your Google Sheet. This error can appear in the Zap editor or Zap history.
 

Causes

This error occurs when your spreadsheet is protected, preventing Zapier from making any changes to your spreadsheet.
 

How to fix it

To resolve this issue, follow these steps:
  1. Remove protection from the spreadsheet to give Zapier access.
  2. Check your spreadsheet permissions to ensure that your spreadsheet is shared with the account you’re using in your Zap. The account must have:
    • “Viewer” access if you’re using it for Zap triggers.
    • “Editor” access if you’re using it for Zap actions.

 

Related Zapier Community topics to reference for possible guidance: https://community.zapier.com/search?q=google%20sheets%20protected&content_type%5B0%5D=question&source%5B0%5D=community