Best answer

Google Sheets Create Worksheet not adding headers.

Userlevel 1

I need my zap to create two headers on a new worksheet it is creating. I’m using the “Headers” field in the “Create Worksheet” event to add them manually, as seen here:

However, when I attempt to test using this setup, I get this error as a response:

And the worksheet is created but without any headers:

Is this a bug, or am I just missing something?


Best answer by ken.a 21 July 2023, 08:01

View original

3 replies

Userlevel 7
Badge +6

Hi there @Ryan Tripi,

Colons (:) in spreadsheet and worksheet titles can sometimes cause this error in a Zap. Taking a closer look at your screenshot, it seems that the "Title" field uses the zap_meta_human_now, which includes colons due to the time format.

Could you please try adding a Date / Time Formatter - Format Date step to your Zap? This will help you convert the zap_meta_human_now to a format without the time, avoiding any potential issues with colons. Once you've done that, just map the output of the Formatter step to the "Title" field.

Please give that a try, and let me know how it goes. 😊

Userlevel 1

That worked, thank you

Userlevel 7
Badge +6

Hi @Ryan Tripi,

Awesome! I’m glad that worked!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 😊