Best answer

Google My Business Quota exceeded for quota metric 'V4 General Requests' and limit 'V4 General Requests per minute' of service

  • 12 September 2022
  • 30 replies
  • 1359 views

Userlevel 1

Getting these messages for the past few days: 

Trigger partner failure: Unable to retrieve reviews: Quota exceeded for quota metric 'V4 General Requests' and limit 'V4 General Requests per minute' of service 'mybusiness.googleapis.com' for consumer 'project_number:466514807953'.

 

This is not a problem withmy Zaps. This seems indicative of a platform limitation between Zapier and Google APIs. Please advise.

icon

Best answer by SamB 2 October 2023, 12:17

View original

30 replies

Userlevel 7
Badge +8

Hi @Code4food , 

 

It seems you are exceeding your Quota limits. Google does have a very high API limit though so not sure why you would run into that error. You can read more about the API Limits here

 

https://developers.google.com/analytics/devguides/reporting/core/v4/limits-quotas

 

This is in regards to Google Analytics, you can google your app if its not this one to check what are your API Limits

Userlevel 1

No, I am not. My customers get one to two Google Business Profile reviews per week. Hardly an extreme case. In addition there are only five Zaps in our account set up that are triggered by Google. Again, not extreme at all. Thus clearly an issue between Zapier and Google. It is similar to the YouTube issues Zapier is having.

Userlevel 7
Badge +8

In this case, you might wanna open a ticket with support@zapier.com so they can help you with it 

Userlevel 7
Badge +9

Hey there, @Code4food! I wanted to pop in and see if you were still seeing this error?

If so, I’d definitely recommend reaching out to support as @MohSwellam mentioned. They’ll be able to dig into your logs and hopefully get to the bottom of this with you.

Keep us posted! 

Userlevel 1

Yes, I did reach out to Support. Nothing yet. In fact, I have two tickets in now: one for the issue I asked about above, and one for a Facebook error that comes sometimes appears when using Zapier to place a a photo post:

Facebook Pages

Please reduce the amount of data you're asking for, then retry your request

 

Zapier is aware, but nothing has come of it yet. 

Userlevel 7
Badge +9

Thanks for the update! I hope you don’t mind - I wanted to get some additional clarity.

I did some digging under the email address for this profile and saw 2 tickets were opened but nothing related to this error, specifically. 😔 Is there another place I could look for you? Full transparency, the reason we’re recommending continuing the troubleshooting process with support is they have access to view your individual zaps and the logs related to these errors - which is really the only way to determine what’s causing this. 

That said, I can see both of these emails (one related to a different Google Business error and the Facebook Pages one listed above) did receive a reply. If you're not seeing those responses, I might recommend checking your spam/junk folder in case it’s ended up there by mistake. If it's not there, it might be worth searching your whole email inbox for emails ending in ‘@zapier.com’.

Appreciate your help in getting to the bottom of this, @Code4food

Userlevel 1

Okay, you beat me into submission so I entered a ticket about this specific issue. This problem seems very similar to the issue Zapier was having with Youtube, which was a limit of some kind was being reached with Zapier’s Youtube API integration, and developers were encountering the same sort of problem I reported here. It seems to be a limit that Zapier may be exceeding, and a higher limit may be needed to resolve the issue. Just a guess, but we’ll see. The error is “Trigger partner failure: Unable to retrieve reviews: Quota exceeded for quota metric 'V4 General Requests' and limit 'V4 General Requests per minute' of service 'mybusiness.googleapis.com' for consumer 'project_number:466514807953'.”

Userlevel 7
Badge +9

Heard. Thanks for that and let us know what ya’ll are able to find out together!

Userlevel 1
Badge

Any updates on this? I am getting the same error.

Hey @christina.d - we’re also having this exact same problem. 

Our Zap only runs each time we get a new review from Google My Business (1-3 times per week) so it’s a bit strange that we’re getting this error about exceeding our quota.

Do you have any updates on this?

Thanks so much

I google the error and came across this … I can confirm exactly the same issue. Maybe 5 reviews per week.

‘Trigger partner failure: Unable to retrieve reviews: Quota exceeded for quota metric 'V4 General Requests' and limit 'V4 General Requests per minute' of service 'mybusiness.googleapis.com' for consumer 'project_number:466514807953'.

Userlevel 1

Any updates on this? Running through the same issue. I just started using zappier, and it barely runs once a week. I can’t possibly be hitting the API limit, not even close.

I am getting the same issue for Google Forms as my trigger 

 

Trigger partner failure: Quota exceeded for quota metric 'Expensive Reads' and limit 'Expensive Reads per minute' of service 'forms.googleapis.com' for consumer 'project_number:927538837578'.

hey so basically the error can sometimes happen because of an initial error. The ZAP is running like every 2 minutes for example because if it was running like every 0.5 seconds than you’d need some serious hardware and not to mention a fat wallet. So when the initial error happens the zap experiences an error for one reason or another, thus causing the zap to fail to run complete. In our case we’re pulling reviews from google my business so it doesn’t reply to the review. Most of you said you guys aren’t getting a lot of reviews but if you wait like 2-3 more reviews then the zap wont have the same issue. go to the history of the zap and see if you get an option to retry the zap. Most likely, the zap will run again and be successful but if you’ve manually replied to the review already it would be pointless. If you don’t get the option to retry the zap its probably saying waiting on one part of your workflow. you have to remember that this is a third party app that is acting as an interface between primary apps so there’s going to be some inevitable time outs and subsequent time out errors. so you can try to manually run the zap and see if it works now. If it doesnt Zapier needs to figure out a solution.

Userlevel 7
Badge +11

Hello there @Code4food, @mgm8870, @RedKiteDesign@Ricardo111, @ZapGG, @mlp0895 and @HOS. 👋

I’ve just been looking into these errors and it turns out there’s an open bug report for this very issue! So you’ve all been added to the list of folks being impacted by this issue. I can’t make any promises around when this would be resolved by but you will all definitely be sent an email notification as soon as it is.

In the meantime you may be able to try replaying the failed run of the Zap a little while later, as HOS mentioned, and have it go through successfully - see: Replay failed Zap runs. Not an ideal or guaranteed solution I know, so I’m sorry for any additional hassle caused by this. Thank you all for your patience while this is being looked into. 🙂

Userlevel 1
Badge +1

Yep, running in the same bug. It's exhausting, this is taking roughly 75% of my Zapier error resolution time.

This problem just started for me as well.

Same issue for us

Running into this issue too

Userlevel 7
Badge +11

I’m so sorry about missing your replies here previously, @xavierB, @Beadz, @Jarvid and @Smuckers

There’s still no ETA on when this will be resolved by, but I can confirm that you’ve been added to the list so you will all be emailed the minute it’s been fixed. If we come across any news or potential workarounds we’ll be sure to share details of them here. Thanks for your continued patience and understanding in the meantime.

I think it’s the same thing we’re now hitting, but it’s happening when trying to turn a zap on - we get an email with the quota limit hit for google business, and the zap doesn’t turn on.

It started with the zap not being triggered for a few weeks even though we had google reviews coming in. (that is specifically that the zap wasn’t triggered, rather than it being triggered and erroring).

We have sort of worked around this now by duplicating the zap and running that one instead 😅.

Same issue.  It looks like my last successful Zap was on Nov 29th.  I assume by the number of people having this problem Zapier is working on a fix?  Is this a hover-in-place situation or something we need to do?

Hello, my name is Faaris. For now, I am addressing it by conducting a retest on my ZAP :)

Same issue here, any news?

Reply