Question

Google Doc template - only 2 markers are recognized within the zap

  • 25 May 2023
  • 5 replies
  • 43 views

Hello

 

I created a google doc template - it shows up in the zap but I only 2 two out of 21 markers from the template???

All do have the same syntex {{NAME}}

Thanks


5 replies

Userlevel 7
Badge +14

Hi @markusfromvienna 

Good question.

My template fields aren't appearing in Zapier or they all have generic names

This may be due to your template format. Remove any HTML formatting, and check your template field formatting.

Remove any HTML formatting

If you copy and pasted fields in your template, they may contain HTML formatting. The HTML formatting won't be visible in your Google Doc, but you will need to remove it before using your Doc in Zapier.

There are two ways to delete the HTML in your Google Docs template:

Manually enter the template field

  1. Delete the template field and the text around the template field
  2. Manually type in the template field and the text around it.

Remove formatting

  1. Highlight the template fields.
  2. In the top menu, click Format.
  3. Select Clear formatting.

If you already selected the template in your Zap, click Refresh fields at the bottom of your Google Docs step. This will reload your template and display your template fields.

Check your template field formatting

To correctly format your template fields in Google Docs:

  • Template fields must be wrapped in double curly braces.
  • Remove any spaces.
  • Remove any special characters like punctuation marks.
Example

Here’s an example of a properly formatted template field: {{MyTemplateField}}.

Learn more about how to create and autopopulate a Google Docs template.

Thank you !

 

It works now. And how to embed an image from a GDRIVE Url? which is stored in a gsheet columen 

{{image}} - it just print on the url ..not the image

BR Markus

 

Userlevel 7
Badge +14

@markusfromvienna 

If it’s supported it would need to be within a HTML image tag: https://www.w3schools.com/tags/tag_img.asp

The image URL also needs to be publicly accessible.

not working in google docs - sad

 

Userlevel 7
Badge +14

@markusfromvienna 

We’d need to see detailed screenshots with how your Zap step is configured.

Reply