Question

Google Doc : Create document from template does not display any file


Userlevel 1

Hello,

In my zap, I have a email parser trigger (ok), then a filter (ok), then a “Create Document from Template in Google Docs” action. In that last action, I set

  • step 2 : create document from template ; OK
  • step 3 : Google doc account : I can select it : OK
  • step 4 : I configure “Folder for new Document” and go into the folder which contains my template files, and then, I click into “Folder for new Document” : nothing is displayed. It does not show any file here. 

I can’t understand why because that already worked before, and :

  1. I checked the connexion of the Google Doc app : it is ok. I tried to reconnect it, without luck. 
  2. I checked the sharing permissions on the folder I want to use in my Zap at step 4 : my Google account is the owner and sharing settings are set on “everybody with the link can EDIT” so It’s the largest permissions that I can set on that folder.
  3. My template files are Google Doc files, in that folder, and I can see them, edit them.
  4. I even tried to login with Firefox or Safari, trashing my cache, … 
  5. I tried to write the id in the Template Document > Custom fields as documented but that does not work.
  6. I tried to create a new zap, that does not work.

I can’t anymore select any template file in that folder… But it was working some days ago. WHY ??

Could you help me please ? What’s wrong ? What didn’t I checked ?? 

Thanks,

A.

 


6 replies

Userlevel 7
Badge +9

Hey there, @airelle. So sorry to hear you’re running into this and thank you so much for the detailed outline of the steps you took to troubleshoot! It’s super helpful. 
For this particular instance, I’d actually recommend opening a ticket with our friends in support.

There’s a few things it could possibly be and it may take a bit of digging into the specifics of your zap to determine a solution for you.
That said, feel free to link back to this post so you don’t need to retype the steps you’ve taken thus far! Please keep us posted! 

Userlevel 1

Ok… I opened a ticket but… I’m feeling that quite unstable and I pay each month for trying that service. I hope that the support will be quick… 

Userlevel 7
Badge +14

Hi @airelle 

Good question.

Try this…

Use the ‘custom’ option and manually set the GDoc ID (found in the browser URL).

Userlevel 1

Hi @airelle 

Good question.

Try this…

Use the ‘custom’ option and manually set the GDoc ID (found in the browser URL).

Hello,

Please have a look inside my question : I already tried it and I wrote that it did not work as expected (I read documentation before asking).

Thanks ! 

Userlevel 7
Badge +14

@airelle

Can you post screenshots with how your GDoc Zap step is configured in order for us to have context?

 

Is your GDoc template properly formatted with the {{placeholder}}?

 

My template doesn't appear in the Create Document from Template Action step

The Create Document from Template Action will only display templates that you created in Google Docs. It won't display existing templates created by Google Docs. Learn more about each template type.

 

My template fields aren't appearing in Zapier or they all have generic names

This may be due to your template format. Remove any HTML formatting, and check your template field formatting.

Remove any HTML formatting

If you copy and pasted fields in your template, they may contain HTML formatting. The HTML formatting won't be visible in your Google Doc, but you will need to remove it before using your Doc in Zapier.

There are two ways to delete the HTML in your Google Docs template:

Manually enter the template field

  1. Delete the template field and the text around the template field
  2. Manually type in the template field and the text around it.

Remove formatting

  1. Highlight the template fields.
  2. In the top menu, click Format.
  3. Select Clear formatting.

If you already selected the template in your Zap, click Refresh fields at the bottom of your Google Docs step. This will reload your template and display your template fields.

Check your template field formatting

To correctly format your template fields in Google Docs:

  • Template fields must be wrapped in double curly braces.
  • Remove any spaces.
  • Remove any special characters like punctuation marks.
 
Example

Here’s an example of a properly formatted template field: {{MyTemplateField}}.

Learn more about how to create and autopopulate a Google Docs template.

 

Userlevel 7
Badge +8

Hey @airelle just checking in here! I see you opened a ticket with our support team, who responded to you on Monday with some questions. Are you still having issues here? If so, following up on your support thread will likely be the best course of action in getting this resolved. Let us know what the issue ended up being once this is all sorted out!

 

Reply