Best answer

Google Calendar 'Attendee Emails' variable has no data?

  • 21 May 2022
  • 8 replies
  • 82 views

First time using Zapier here. I’m trying to create a Zap that sends a reminder email (via Gmail) to all meeting attendees fifteen minutes before each meeting on a shared Google Calendar. The problem is that that the “attendee emails” variable for the events always comes up with “no data” and thus, won’t send to anybody. I’ve tested everything else, and it works if I add my own email by hand, but nobody else appear on the “to” list.

The only thing I could think of is that it’s because I’m using GCalendar’s bookable appointment scheduling feature, and that somehow doesn’t enter attendee’s emails? Any advice would be helpful.

icon

Best answer by Danvers 25 May 2022, 16:21

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @kaychrisa 

Good question.

Have you read this help article?

How to Pull Specific Events When Using the Event Start Trigger

Hi @kaychrisa 

Good question.

Have you read this help article?

How to Pull Specific Events When Using the Event Start Trigger

 

I hadn’t, thanks for the link. When I was messing around with it before, I got Zapier to pull a real past event, which seemed to be fine except for the attendee_emails variable (screenshot below).

 

Unfortunately this calendar is for meetings with people I never talk to again, so I can’t really send spam to their mailbox while I test this. So I followed the tutorial you sent to create a new event on the calendar, then put the event name as search term, but now it’s only started pulling the test data and won’t pull the new event I created or the old event it was pulling before, even after I removed the search term.

Userlevel 7
Badge +14

@kaychrisa 

If you have another email address, you can test with that.

If you have a Gmail address, then you can create unique email addresses to use to test, here’s how: https://support.google.com/a/users/answer/9308648?hl=en

@kaychrisa

If you have another email address, you can test with that.

If you have a Gmail address, then you can create unique email addresses to use to test, here’s how: https://support.google.com/a/users/answer/9308648?hl=en

I did invite my second Gmail to the test event I made.

Userlevel 7
Badge +12

Hi @kaychrisa!

I took a look at the notes that we have for the Google Calendar app and 1) this should be possible and 2) I couldn’t find anything about  GCalendar’s bookable appointment scheduling feature interfering with it, so that’s not a known issue.

I just tested the Event Start trigger using the method described in the help doc above and it worked for me:

You can see that I invited ‘myemail+1’ to the event and both my email and that duplicate email show up as attendees. 

I know that you’ve already tried a lot, but could you give something else a go? Could you create a brand new test event that starts within the appropriate time period. You don’t have to name it anything specific, but make sure there aren’t any specific search terms in the set up of the step. When you set up the event, add your second/fake email address. If you have a gmail email account, you can simply add ‘+1’ after your name (eg if your email was captain.america@gmail.com, add captain.america+1@gmail.com). As soon as you’ve done that, head back to the Zap and re-test the trigger. Fingers crossed that will work for you, let us know if you’re still having trouble!

Nope.

Hi @kaychrisa!

I took a look at the notes that we have for the Google Calendar app and 1) this should be possible and 2) I couldn’t find anything about  GCalendar’s bookable appointment scheduling feature interfering with it, so that’s not a known issue.

I just tested the Event Start trigger using the method described in the help doc above and it worked for me:

You can see that I invited ‘myemail+1’ to the event and both my email and that duplicate email show up as attendees. 

I know that you’ve already tried a lot, but could you give something else a go? Could you create a brand new test event that starts within the appropriate time period. You don’t have to name it anything specific, but make sure there aren’t any specific search terms in the set up of the step. When you set up the event, add your second/fake email address. If you have a gmail email account, you can simply add ‘+1’ after your name (eg if your email was captain.america@gmail.com, add captain.america+1@gmail.com). As soon as you’ve done that, head back to the Zap and re-test the trigger. Fingers crossed that will work for you, let us know if you’re still having trouble!

Nope. I also deleted the old Zap and created an entirely new Zap to test with both creating the event by hand and GCalendar’s autobook feature. Attached are the respective screenshots of both events I created and my Zap settings.

 

Userlevel 7
Badge +12

Hi @kaychrisa I’m sorry that this is proving really tricky.

If I had to guess I would say that you’re right and this is related to the bookable feature as it seems to work when an event is created manually. There’s nothing else that I can run through with you in the Community, so I think it’s best to get in touch with the Support Team at this point. Use the Get Help form and you can include a link to this thread so you don’t have to share all of the same screenshots again. Sorry that I wasn’t able to help out on this one!

Hi @kaychrisa I’m sorry that this is proving really tricky.

If I had to guess I would say that you’re right and this is related to the bookable feature as it seems to work when an event is created manually. There’s nothing else that I can run through with you in the Community, so I think it’s best to get in touch with the Support Team at this point. Use the Get Help form and you can include a link to this thread so you don’t have to share all of the same screenshots again. Sorry that I wasn’t able to help out on this one!

I don’t think it’s the only issue, because as you can see the first screenshot is an event I created by hand, and that isn’t working either. But I will go to support.

For anyone reading this thread in archive, I also tried making the GCalendar public and that didn’t work. I’ll update if support is able to fix the issue. If I don’t update, assume the issue can’t be fixed.