Best answer

Gmail error: The app returned "404. That's an error. The requested URL was not found on this server

  • 3 August 2023
  • 8 replies

Userlevel 1

The Problem:

I am linking Google Sheets with an automated Gmail email push for every new submission (every new row). I am getting an error message reading:

The app returned "404. That’s an error.The requested URL was not found on this server. That’s all we know.".



There are four steps in the process (image attached):

  1. Trigger - New Row Added to Google Sheet
  2. Gmail Push (Internal) - Pushing Email to internal team containing info submitted within the Google Sheet
  3. Gmail Push (External) - Pushing Email to submitee containing info submitted within the Google Sheet
  4. Notion New Row - Duplication of information from Google Sheet into Notion database row


The Confusing Part:

When I test the Zaps individually, they all work (yes, the Gmail actions too). However, when there is a new submission to the Google Form, I get the error message outlined above. Yet, somehow the Notion Database is updated and reflects the proper information.


I have tried shifting the order of the sequence, re-linking my email, and submitting multiple times, all to no avail….

Any suggestions?


Best answer by Z-S54 3 August 2023, 18:54

View original

8 replies

Userlevel 7
Badge +14

Hi @Z-S54 

Good question.

Check your Zap Runs history details to see the DATA IN/OUT for each Zap step to help you troubleshoot:

We would need to know which of the Gmail steps is resulting in the error.

We would need to see screenshots which how your Zap steps are configured.

Userlevel 1

Thanks for the quick note! 

It appears that it’s both 2 & 3 (both of the Gmail steps)…


Userlevel 7
Badge +14


We would need to see screenshots which how your Gmail Zap steps are configured.


Also, check your Gmail Zap app connection:

Userlevel 1

@Troy Tessalone 
Apologies! Additional images attached:



Userlevel 7
Badge +14


One thing to check is that the Attachment GDrive link is a publicly accessible direct download link for a file.


Userlevel 1

@Troy Tessalone 

No luck… Any other ideas?

Userlevel 1

@Troy Tessalone 

I just figured it out! The answer was close to what you said about the status of the link. One of the AI Troubleshoot recommendations was:


The error message “The app returned ‘404. That’s an error. The requested URL was not found on this server. That’s all we know.’” indicates that the URL provided in the “file” field of the input data is not valid or does not exist. 

To resolve this error, you should check the URL in the “file” field and make sure it is correct and accessible. Ensure that the URL is properly formatted and points to a valid file or resource. If the URL is incorrect or expired, update it with the correct URL.


The Solution 

was to completely delete the attachments to the email (termed as items in the “file field”). Since I pasted the link to the file in the email already, the file is already attached-- maybe that’s why it wasn't working in the first place because it was attempting to post the same thing twice and was confused? Either was, problem solved.

Thanks for the help Troy! 

Userlevel 5
Badge +7

They there @Z-S54 - wanted to send a quick note of appreciation for you coming back in and sharing what worked for your Zap, this is incredibly helpful if other people run into similar error messages in the future. Come back any time, and for now I’ll mark your reply as the best answer! Best- Rachael