Freshsales error adding your account: Authentication failed, the app returned "404"

  • 2 August 2023
  • 7 replies

Hi, screenshot below - when I try to connect my freshsales account I get this message, I’ve tried different browsers and checked permissions in freshsales, I’m now out of ideas! Thank you :) 



7 replies

Userlevel 7
Badge +14

Hi @EllieVHD 

Good question.

Make sure you are inputting the correct values as per the instructions.

Make sure there are no leading/trailing spaces in the input values.


Hi, thanks, yeah I’ve checked (a lot, haha), just keep getting the same error message

Userlevel 7
Badge +14


If you have a Zapier paid plan, you can try opening a ticket with Zapier Support:

Might be worthwhile to also try contacting Freshsales Support.

Thanks Troy

Userlevel 7
Badge +11

Hey @EllieVHD! 👋

Just wanted to check in here. Were you able to get this solved by reaching out to the Freshsales Support team as Troy suggested? 

If not, I did some digging and found instances of that same error where our Support team was able to see some more details for the error in the logs. Specifically they were seeing this message: “Incorrect or expired API key”.

Not sure if that’s the cause of the error in your situation too but thought it worth mentioning here in case resetting the API key sorts it. Looking forward to hearing from you!

Hey @SamB 

Thanks for coming back to this. Sadly I didn’t get anywhere with the Freshsales Team (anybody else think their support is baaaad?!) so just tried resetting the API as you suggested, also no luck.

Thank you for trying :) 

Userlevel 7
Badge +11

Sorry that didn’t work as hoped and that you’ve not heard back from the Freshsales support team yet @EllieVHD.

The only other thing I can think of is that maybe the Freshsales account you’re attempting to connect to isn’t supported. Going by the Freshsales documentation here it seems that the Sprout plan isn’t supported:

Are you on their Sprout plan?

If not then it may be worth reaching out to the Zapier Support team as Troy mentioned earlier, as it could well be a bug with the Freshsales app that needs further investigation. 

Please do keep us in the loop on how you get on with this! 🙂