Firebase "The Account is Expired"

  • 10 February 2023
  • 1 reply

I have created 4 Zaps that all grab data from a firebase collection, then execute different commands.


Every day I get an error message “The Account is Expired” and the Zaps don’t run

I’ve reached out to support but they don’t have any answer, has anyone experienced this before and how can I resolve it?

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +12

Hi @tomg12345, welcome to the community!


I can see that the Support team got back to you with this reply:

I was able to look in our logs and I am seeing a 400 error "Invalid grant". Have you tried creating a brand new Firebase connection within the Zap? If not, I'd recommend giving that a try.
I also did some research and found that generating a new SDK key may help as well. Once that is done, try reconnecting the account once more.
Additionally, reaching out to Firebase/Firestore may help as well, as their support team may be able to take a closer look at your account to see if any setting need to be updated


If you’ve tried the suggestions above and it didn’t help I’d recommend going back to the Zapier Support team, explaining the steps you’ve taken and they can take another look to see if we’re still getting the same error message in the Zap logs.